[ros-dev] Thankyou everybody, but still i dont manage to compile it.

Lucio Diaz reactos_translate at yahoo.es
Sun Jan 9 07:04:31 CET 2005


 --- ros-dev-request at reactos.com escribió: 
> Send Ros-dev mailing list submissions to
> 	ros-dev at reactos.com
> 
> To subscribe or unsubscribe via the World Wide Web,
> visit
> 	http://reactos.com:8080/mailman/listinfo/ros-dev
> or, via email, send a message with subject or body
> 'help' to
> 	ros-dev-request at reactos.com
> 
> You can reach the person managing the list at
> 	ros-dev-owner at reactos.com
> 
> When replying, please edit your Subject line so it
> is more specific
> than "Re: Contents of Ros-dev digest..."
> 
> 
> Today's Topics:
> 
>    1. Re: Anyone to help a newbie? (Anich Gregor)
>    2. RE: Application Regression (vim.exe) (Ge van
> Geldorp)
>    3. tickcount (David Kredba)
>    4. RE: [ros-svn] [hyperion] 12838: honor
> __USE_W32API
>       (Ge van Geldorp)
>    5. Creative SB Live audio card : Driver loading
> fails (Gge)
>    6. Re: Application Regression (vim.exe)
> (WaxDragon)
>    7. Wine I/O Manager for Kernel Services (Brad
> DeMorrow)
>    8. /nt Removal Patch (Alex Ionescu)
> 
> 
>
----------------------------------------------------------------------
> 
> Message: 1
> Date: Wed, 5 Jan 2005 15:14:28 +0100
> From: Anich Gregor <blight at blight.eu.org>
> Subject: Re: [ros-dev] Anyone to help a newbie?
> To: ros-dev at reactos.com
> Message-ID:
> <200501051514.28630.blight at blight.eu.org>
> Content-Type: text/plain;  charset="iso-8859-1"
> 
> On Wednesday 05 January 2005 00:44, Lucio Diaz
> wrote:
> > I installed the SVN and could make it work, i
> > downloaded MinGW-3.1.0-1.exe ,gcc-core 3.3.3 ,
> gcc-g++
> > 3.3.3 and nasm-0.98-win32.zip Installed them and
> set
> > the path.
> >
> >
> > i tried to build ReactOs (at the reactos folder)
> with
> > make (I did previously a make clean)
> >
> > And i get the following error:
> >
> > Compiling arch/i386/i386rt
> > l
> > cc1.exe: unrecognized option
> > `-fno-zero-initialized-in-bss'
> > make[2]: *** [arch/i386/i386rtl.o] Error 1
> > make[1]: *** [all] Error 2
> > make: *** [freeldr] Error 2
> >
> > C:\Internet\ReactOS\Subersion\trunk\reactos>
> 
> What's the output of gcc -dumpversion? Are you sure
> you have 3.3.3 installed? 
> 
> >
> > ------------------------------------------------
> >
> >
> > Nevertheless i try to make install and get the
> > following error:
> >
> > make[1]: *** No rule to make target
> > `../../dk/w32/lib/libvfatlib.a', needed by `
> > fmifs.nostrip.dll'.  Stop.
> > make: *** [fmifs_install] Error 2
> >
> > C:\Internet\ReactOS\Subersion\trunk\reactos>
> >
> 
> This happend because "make install" doesnt do the
> same as "make && make 
> install" - you have to "make" once for things like
> dk/w32/lib/libvfatlib.a to 
> be built.
> 
> >
> > I dont know what i am making wrong, any idea?
> >
> >
> > Thanks in advance and my best wishes for 2005.
> 
> - blight
> 
> ------------------------------


Thankyou for your help, i was using "make", geting the
error and then trying to "make install" (of course
getting another error).

Once i did -dumpversion i realized i had the version
3.2.3 (even if the ziped files stated 3.3.3 a typo i
supouse) so i updated to 3.4.2

Again i tried "make"... and then i ran out of memory
somewere with rosrtl

I set the virtual memory up to 2Gigas...

Then i went further and got an error about not finding
cc1 where it belongs...so i put (and all the files in
that folder)it where gcc was searching for them.

Now i can avance further, but even making a "make
clean" and going with "make" again i get stuck with
cc1.exe Now gcc fings it, but it gives an error about
not understanding some comand or argument:

rosrtl: [DEPENDS] thread/.create.d
rosrtl: [DEPENDS] misc/.intrlck.d
gcc: installation problem, cannot exec
`C:\Internet\ReactOS\Subersion\MinGW\bin\
..\libexec\gcc\mingw32\3.4.2\cc1.exe': Invalid
argument
rosrtl: [DEPENDS] misc/.devmode.d
gcc: installation problem, cannot exec
`C:\Internet\ReactOS\Subersion\MinGW\bin\
..\libexec\gcc\mingw32\3.4.2\cc1.exe': Invalid
argument
rosrtl: [DEPENDS] thread/i386/.context.d
gcc: installation problem, cannot exec
`C:\Internet\ReactOS\Subersion\MinGW\bin\
..\libexec\gcc\mingw32\3.4.2\cc1.exe': Invalid
argument
rosrtl: [DEPENDS] thread/.linearstack.d
gcc: installation problem, cannot exec
`C:\Internet\ReactOS\Subersion\MinGW\bin\
..\libexec\gcc\mingw32\3.4.2\cc1.exe': Invalid
argument
rosrtl: [DEPENDS] thread/.priv.d
rosrtl: [DEPENDS] thread/.stack.d
rosrtl: [DEPENDS] thread/.exit.d
rosrtl: [DEPENDS] thread/.create.d
gcc: installation problem, cannot exec
`C:\Internet\ReactOS\Subersion\MinGW\bin\
..\libexec\gcc\mingw32\3.4.2\cc1.exe': Invalid
argument
rosrtl: [DEPENDS] thread/.priv.d
gcc: installation problem, cannot exec
`C:\Internet\ReactOS\Subersion\MinGW\bin\
..\libexec\gcc\mingw32\3.4.2\cc1.exe': Invalid
argument
El sistema no puede ejecutar el programa especificado.
make[1]: *** [thread/.priv.d] Error 255
make: *** [rosrtl] Error 2

The cc1.exe states its version is 3.4.2.I  have also
updated the SVN tree a few times with the same
problem.I dont know where is the problem, please help,
i cant imagine what i am doing wrong.

Thanks all for your help and good luck.


		
______________________________________________ 
Renovamos el Correo Yahoo!: ¡250 MB GRATIS! 
Nuevos servicios, más seguridad 
http://correo.yahoo.es


More information about the Ros-dev mailing list