Handbrake Transcoding with strange color issues

If it doesn't fit anywhere else, drop it in here. (not to be used as a chat/nonsense section)

Moderator: Moderator Team

Handbrake Transcoding with strange color issues

Postby coldReactive » Fri Jun 12, 2009 4:39 pm

Wondering if ReactOS people can help, since I'm still waiting for a reply on the official handbrake forums.

See in this youtube video: http://www.youtube.com/watch?v=6_lPAQ4NXyM

Notice the blue tint on certain things, as well as pinkish tint and the title bar glitches. This is from a lossless codec to H.264 MP4. I cannot choose MKV, because Handbrake gets stuck at 0.00%

Code: Select all
### Windows GUI 0.9.3 2008112300
### Running: Microsoft Windows NT 6.0.6001 Service Pack 1
###
### CPU: AMD Phenom(tm) 8400 Triple-Core Processor
### Ram: 1790 MB
### Screen: 1440x900
### Temp Dir: C:\Users\Izek\AppData\Local\Temp\
### Install Dir: C:\Program Files (x86)\HandBrake
### Data Dir: C:\Users\Izek\AppData\Roaming\HandBrake\HandBrake\0.9.3.0
#########################################

[13:20:19] hb_init: checking cpu count
[13:20:19] hb_init: starting libhb thread
HandBrake 0.9.3 (2008112300) - http://handbrake.fr/
3 CPUs detected
Opening C:\Users\Izek\Videos\blah3.avi...
[13:20:19] hb_scan: path=C:\Users\Izek\Videos\blah3.avi, title_index=1
[13:20:19] scan: trying to open with libdvdread
[13:20:19] dvd: not a dvd - trying as a stream/file instead
Input #0, avi, from 'C:\Users\Izek\Videos\blah3.avi':
  Duration: 00:00:37.80, start: 0.000000, bitrate: 7075 kb/s
    Stream #0.0: Video: camstudio, rgb32, 1440x900, 50.00 tb(r)
    Stream #0.1: Audio: pcm_s16le, 44100 Hz, stereo, s16, 1411 kb/s
[13:20:19] scan: decoding previews for title 1
Scanning title 1...
Scanning title 1...
[13:20:20] scan: 10 previews, 1440x900, 50.000 fps, autocrop = 0/0/0/0, aspect 1.60:1, PAR 1:1
[13:20:20] Title is likely interlaced or telecined (10 out of 10 previews). You should do something about that.
[13:20:20] scan: title (0) job->width:1440, job->height:896
[13:20:20] libhb: scan thread found 1 valid title(s)
+ title 1:
  + vts 0, ttn 0, cells 0->0 (0 blocks)
  + duration: 00:00:37
  + size: 1440x900, aspect: 1.60, 50.000 fps
  + autocrop: 0/0/0/0
  + chapters:
    + 1: cells 0->0, 0 blocks, duration 00:00:37
  + audio tracks:
    + 1, Unknown (PCM_S16)
  + subtitle tracks:
  + combing detected, may be interlaced or telecined
Modified x264 options for pass 1 to append turbo options: ref=2:bframes=2:me=umh:ref=1:subme=1:me=dia:analyse=none:trellis=0:no-fast-pskip=0:8x8dct=0:weightb=0
[13:20:20] 2 job(s) to process
[13:20:20] starting job
[13:20:20] work: sanitizing track 0 mixdown Dolby Pro Logic II to Stereo
[13:20:20] job configuration:
[13:20:20]  * source
[13:20:20]    + C:\Users\Izek\Videos\blah3.avi
[13:20:20]    + title 1, chapter(s) 1 to 1
[13:20:20]    + container: avi
[13:20:20]    + data rate: 7075 kbps
[13:20:20]  * destination
[13:20:20]    + C:\Users\Izek\Videos\blah3.mp4
[13:20:20]    + container: MPEG-4 (.mp4 and .m4v)
[13:20:20]  * video track
[13:20:20]    + decoder: camstudio
[13:20:20]    + frame rate: same as source (around 50.000 fps)
[13:20:20]    + strict anamorphic
[13:20:20]      + storage dimensions: 1440 * 900 -> 1440 * 900, crop 0/0/0/0
[13:20:20]      + pixel aspect ratio: 1 / 1
[13:20:20]      + display dimensions: 1440 * 900
[13:20:20]    + encoder: x264
[13:20:20]      + options: ref=2:bframes=2:me=umh:ref=1:subme=1:me=dia:analyse=none:trellis=0:no-fast-pskip=0:8x8dct=0:weightb=0
[13:20:20]      + bitrate: 800 kbps, pass: 1
[13:20:20]  * audio track 0
[13:20:20]    + decoder: Unknown (PCM_S16) (track 1, id 1)
[13:20:20]    + mixdown: Stereo
[13:20:20]    + encoder: faac
[13:20:20]      + bitrate: 160 kbps, samplerate: 44100 Hz
[13:20:20] dvd: not a dvd - trying as a stream/file instead
[13:20:20] encx264: keyint-min: 51, keyint-max: 501
[13:20:20] encx264: encoding with stored aspect 1/1
x264 [warning]: width or height not divisible by 16 (1440x900), compression will suffer.
x264 [info]: using SAR=1/1
x264 [info]: using cpu capabilities: MMX2 SSE2Fast
x264 [info]: profile Main, level 4.2
[13:20:20] reader: first SCR 0
[13:20:20] sync: expecting 1940 video frames
[13:20:20] sync: adding 800 ms of silence to audio 0  start 72000, next 0
[13:21:00] reader: done. 1 scr changes
[13:21:09] sync: got 500 frames, 1940 expected
[13:21:09] work: average encoding speed for job is 10.255883 fps
[13:21:14] camstudio-decoder done: 501 frames, 0 decoder errors, 0 drops
[13:21:14] render: lost time: 0 (0 frames)
[13:21:14] render: gained time: 0 (0 frames) (0 not accounted for)
x264 [info]: slice I:5     Avg QP:19.50  size:117484  PSNR Mean Y:44.68 U:50.65 V:50.74 Avg:45.85 Global:33.73
x264 [info]: slice P:656   Avg QP:14.83  size:  2217  PSNR Mean Y:52.89 U:52.40 V:52.77 Avg:52.72 Global:45.87
x264 [info]: slice B:1228  Avg QP:16.35  size:   378  PSNR Mean Y:52.93 U:52.39 V:52.75 Avg:52.75 Global:45.52
x264 [info]: consecutive B-frames:  2.2%  0.2% 97.6%
x264 [info]: mb I  I16..4: 79.3%  0.0% 20.7%
x264 [info]: mb P  I16..4:  2.1%  0.0%  0.0%  P16..4: 11.1%  0.0%  0.0%  0.0%  0.0%    skip:86.7%
x264 [info]: mb B  I16..4:  0.0%  0.0%  0.0%  B16..8:  0.1%  0.0%  0.0%  direct: 5.9%  skip:94.0%  L0:25.2% L1:74.8% BI: 0.0%
x264 [info]: final ratefactor: 29.55
x264 [info]: SSIM Mean Y:0.9975887
x264 [info]: PSNR Mean Y:52.897 U:52.386 V:52.752 Avg:52.720 Global:45.471 kb/s:530.72
[13:21:14] pcm_s16le-decoder done: 0 frames, 0 decoder errors, 0 drops
[13:21:14] starting job
[13:21:14] work: sanitizing track 0 mixdown Dolby Pro Logic II to Stereo
[13:21:14] job configuration:
[13:21:14]  * source
[13:21:14]    + C:\Users\Izek\Videos\blah3.avi
[13:21:14]    + title 1, chapter(s) 1 to 1
[13:21:14]    + container: avi
[13:21:14]    + data rate: 7075 kbps
[13:21:14]  * destination
[13:21:14]    + C:\Users\Izek\Videos\blah3.mp4
[13:21:14]    + container: MPEG-4 (.mp4 and .m4v)
[13:21:14]  * video track
[13:21:14]    + decoder: camstudio
[13:21:14]    + frame rate: same as source (around 50.000 fps)
[13:21:14]    + strict anamorphic
[13:21:14]      + storage dimensions: 1440 * 900 -> 1440 * 900, crop 0/0/0/0
[13:21:14]      + pixel aspect ratio: 1 / 1
[13:21:14]      + display dimensions: 1440 * 900
[13:21:14]    + encoder: x264
[13:21:14]      + options: ref=2:bframes=2:me=umh
[13:21:14]      + bitrate: 800 kbps, pass: 2
[13:21:14]  * audio track 0
[13:21:14]    + decoder: Unknown (PCM_S16) (track 1, id 1)
[13:21:14]    + mixdown: Stereo
[13:21:14]    + encoder: faac
[13:21:14]      + bitrate: 160 kbps, samplerate: 44100 Hz
[13:21:14] dvd: not a dvd - trying as a stream/file instead
[13:21:14] reader: first SCR 0
[13:21:14] encx264: keyint-min: 51, keyint-max: 501
[13:21:14] encx264: encoding with stored aspect 1/1
x264 [warning]: width or height not divisible by 16 (1440x900), compression will suffer.
x264 [info]: using SAR=1/1
x264 [info]: using cpu capabilities: MMX2 SSE2Fast
x264 [info]: profile Main, level 4.2
[13:21:14] sync: expecting 1940 video frames
[13:21:14] sync: adding 800 ms of silence to audio 0  start 72000, next 0
[13:21:52] reader: done. 1 scr changes
[13:21:58] sync: got 500 frames, 1940 expected
[13:21:58] work: average encoding speed for job is 11.640707 fps
[13:21:58] sync: got 500 frames, 1940 expected
[13:21:58] work: average encoding speed for job is 11.640707 fps
[13:22:02] camstudio-decoder done: 501 frames, 0 decoder errors, 0 drops
[13:22:02] render: lost time: 0 (0 frames)
[13:22:02] render: gained time: 0 (0 frames) (0 not accounted for)
x264 [info]: slice I:5     Avg QP:13.21  size:137334  PSNR Mean Y:49.71 U:56.18 V:56.49 Avg:51.02 Global:50.96
x264 [info]: slice P:657   Avg QP:13.49  size:  1720  PSNR Mean Y:55.18 U:56.02 V:56.40 Avg:55.46 Global:55.37
x264 [info]: slice B:1227  Avg QP:15.03  size:   363  PSNR Mean Y:55.27 U:56.06 V:56.42 Avg:55.53 Global:55.49
x264 [info]: consecutive B-frames:  2.2%  0.3% 97.5%
x264 [info]: mb I  I16..4: 72.5%  0.0% 27.5%
x264 [info]: mb P  I16..4:  0.4%  0.0%  0.1%  P16..4: 10.0%  0.1%  0.0%  0.0%  0.0%    skip:89.3%
x264 [info]: mb B  I16..4:  0.0%  0.0%  0.0%  B16..8:  0.1%  0.0%  0.0%  direct: 3.4%  skip:96.5%  L0:63.8% L1:36.1% BI: 0.1%
x264 [info]: ref P L0  98.6%  1.4%
x264 [info]: SSIM Mean Y:0.9996390
x264 [info]: PSNR Mean Y:55.224 U:56.043 V:56.412 Avg:55.494 Global:55.425 kb/s:478.86
[13:22:02] pcm_s16le-decoder done: 0 frames, 0 decoder errors, 0 drops
[13:22:02] libhb: work result = 0
Rip done!

 ############ End of Log ##############


RAM is actually 6 GB Total. Also, the encoding process stops at 25.77% on both passes and finishes each pass at that percentage.
coldReactive
 
Posts: 581
Joined: Sat Nov 10, 2007 10:42 pm

Return to Off Topic

Who is online

Users browsing this forum: No registered users and 8 guests