0.3.9 Released

ReactOS related news

Moderator: Moderator Team

0.3.9 Released

Postby Ged » Sun Apr 26, 2009 9:50 pm

The latest and greatest has been released.

Please vote for it (digg, reddit, etc) using the buttons at the bottom of the page

http://www.reactos.org/en/news_page_51.html
Ged
Developer
 
Posts: 925
Joined: Thu Sep 29, 2005 3:00 pm
Location: UK

Re: 0.3.9 Released

Postby tomleem » Sun Apr 26, 2009 11:28 pm

I will try to install it on my netbook; an Asus EEE PC 701a. It might not work but I won't know if I do not at least give it a try. :mrgreen:
* * * * * * * * * * * * *
Tom Lee M / BigGoofyGuy
* * * * * * * * * * * * *
tomleem
 
Posts: 553
Joined: Mon Mar 28, 2005 6:59 pm
Location: New Jersey of United States of America

Re: 0.3.9 Released

Postby coldReactive » Mon Apr 27, 2009 6:28 am

Well, I installed it in qEMU under Ubuntu 9.04, but everything takes like 3 minutes to select something.
coldReactive
 
Posts: 581
Joined: Sat Nov 10, 2007 10:42 pm

Re: 0.3.9 Released

Postby lollebol » Mon Apr 27, 2009 12:31 pm

Im getting a bsod at serveral places while installing on Virtualbox 2.2.0 on a Vista x64 host.
http://img256.imageshack.us/img256/7100/rosbsod.png

Anyone knows what this means and how this can be fixed?

Regards,
Lollebol
lollebol
 
Posts: 60
Joined: Tue Mar 17, 2009 6:15 pm
Location: Netherlands

Re: 0.3.9 Released

Postby GoBusto » Mon Apr 27, 2009 12:52 pm

lollebol wrote:Im getting a bsod at serveral places while installing on Virtualbox 2.2.0 on a Vista x64 host.


Possibly unrelated to your problem, but you might want to look at this: viewtopic.php?f=13&t=6784
GoBusto
 
Posts: 579
Joined: Fri Jan 25, 2008 11:13 am
Location: UK

Re: 0.3.9 Released

Postby lollebol » Tue Apr 28, 2009 10:20 pm

It seems like that VirtualBox was the problem.

I have upgraded it to 2.2.2 and no bsod so far :D
lollebol
 
Posts: 60
Joined: Tue Mar 17, 2009 6:15 pm
Location: Netherlands

Re: 0.3.9 Released

Postby coldReactive » Tue Apr 28, 2009 11:15 pm

coldReactive wrote:Well, I installed it in qEMU under Ubuntu 9.04, but everything takes like 3 minutes to select something.


and here's something to back that up:

http://coldreactive.deviantart.com/art/ ... -120798491
coldReactive
 
Posts: 581
Joined: Sat Nov 10, 2007 10:42 pm

Re: 0.3.9 Released

Postby elhoir » Wed Apr 29, 2009 11:39 am

lollebol wrote:It seems like that VirtualBox was the problem.

I have upgraded it to 2.2.2 and no bsod so far :D

so is it fixed?
elhoir
Test Team
 
Posts: 350
Joined: Thu Sep 13, 2007 7:01 pm
Location: Madrid, Spain

Re: 0.3.9 Released

Postby lollebol » Wed Apr 29, 2009 11:44 am

Well the setup of ROS runs fine now without any problems,
but I tried to install virtualbox addions 2.2.2 and that causes another blue screen :(

anyone else had better luck installing the new addions?
lollebol
 
Posts: 60
Joined: Tue Mar 17, 2009 6:15 pm
Location: Netherlands

Re: 0.3.9 Released

Postby Haos » Wed Apr 29, 2009 11:46 am

Its their new mouse driver. You should be able to avoid this crash by deleting vboxmouse.sys from system32\drivers AFTER installing vbox guest additions and BEFORE restarting.
Haos
Test Team
 
Posts: 2954
Joined: Thu Mar 22, 2007 5:42 am

Re: 0.3.9 Released

Postby ermilo2000 » Thu May 21, 2009 11:04 pm

installed on virtualbox on my laptop. installed just fine . wireless network not working. will try wired network.
ermilo2000
 
Posts: 1
Joined: Thu May 21, 2009 10:45 pm

Re: 0.3.9 Released

Postby GoBusto » Mon May 25, 2009 11:47 pm

Haos wrote:Its their new mouse driver. You should be able to avoid this crash by deleting vboxmouse.sys from system32\drivers AFTER installing vbox guest additions and BEFORE restarting.


Update: Fixed now?

Commit by mjmartin :: r41119 reactos/drivers/input/i8042prt/ (misc.c mouse.c):

* i8042MouInternalDeviceControl: Implement IoControlCode of IOCTL_INTERNAL_I8042_HOOK_MOUSE.
* ForwardIrpAndWait: Don't use IoForwardIrpSynchronously to Forward IRPs as it fails if no next stack location is available, which prevents the mouse from initializing. Changed it to match implementation of our other input drivers. Mouse pointer now works with VBoxMouse driver loaded.
GoBusto
 
Posts: 579
Joined: Fri Jan 25, 2008 11:13 am
Location: UK

Re: 0.3.9 Released

Postby Maribo63_4 » Tue May 26, 2009 7:39 am

GoBusto wrote:
Haos wrote:Its their new mouse driver. You should be able to avoid this crash by deleting vboxmouse.sys from system32\drivers AFTER installing vbox guest additions and BEFORE restarting.


Update: Fixed now?

Commit by mjmartin :: r41119 reactos/drivers/input/i8042prt/ (misc.c mouse.c):

* i8042MouInternalDeviceControl: Implement IoControlCode of IOCTL_INTERNAL_I8042_HOOK_MOUSE.
* ForwardIrpAndWait: Don't use IoForwardIrpSynchronously to Forward IRPs as it fails if no next stack location is available, which prevents the mouse from initializing. Changed it to match implementation of our other input drivers. Mouse pointer now works with VBoxMouse driver loaded.


Yes, i have VBox 2.2.2 with guest additions installed, and it works just fine!
Maribo63_4
 
Posts: 72
Joined: Thu Mar 31, 2005 7:43 pm
Location: Neulußheim/Germany

Re: 0.3.9 Released

Postby alexandrius » Sat Jul 18, 2009 7:17 pm

when is planned to release the final or beta version of the OS?
alexandrius
 
Posts: 10
Joined: Thu Jul 16, 2009 6:50 pm

Re: 0.3.9 Released

Postby coldReactive » Sat Jul 18, 2009 7:46 pm

alexandrius wrote:when is planned to release the final or beta version of the OS?


it's done when it's done. Check back next spring, maybe, for beta.
coldReactive
 
Posts: 581
Joined: Sat Nov 10, 2007 10:42 pm

Next

Return to News

Who is online

Users browsing this forum: No registered users and 3 guests