[ros-bugs] [Bug 4165] desk.cpl -> appearance -> selected scheme won't show the preview

ReactOS.Bugzilla at reactos.org ReactOS.Bugzilla at reactos.org
Sun Dec 20 02:34:57 CET 2009


http://www.reactos.org/bugzilla/show_bug.cgi?id=4165


amine48rz <amine48rz at gmail.com> changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
         AssignedTo|ros-bugs at reactos.org        |janderwald at reactos.org

gabrielilardi <gabrielilardi at hotmail.it> changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
                 CC|                            |gabrielilardi at hotmail.it
            Summary|color scheme bug part 2     |desk.cpl -> appearance ->
                   |                            |selected scheme won't show
                   |                            |the preview

maku <mkupfer at reactos.org> changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
                 CC|                            |mkupfer at reactos.org

gabrielilardi <gabrielilardi at hotmail.it> changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
                 CC|                            |ajfweb at googlemail.com




--- Comment #2 from maku <mkupfer at reactos.org>  2009-02-18 16:36:50 CET ---
Apart from the missing WM_SYSCOLORCHANGE message handling, some elements aren't
updated even if you force redraw via WM_SYSCOLORCHANGE message. Surprisingly
the extended dialog for the change of colors works correct though it uses the
same control (PreviewWndClass).


--- Comment #3 from maku <mkupfer at reactos.org>  2009-07-13 00:28:20 CET ---
it's very easy to transfer current settings to preview and force redraw for the
selected color scheme, but unfortunately the DrawEdge-, DrawCaption*- ...
functions always use the current system colors. By using this functions (in
this way) a preview of another color scheme is impossible...


--- Comment #4 from gabrielilardi <gabrielilardi at hotmail.it>  2009-12-20 02:34:56 CET ---
*** Bug 5046 has been marked as a duplicate of this bug. ***


-- 
Configure bugmail: http://www.reactos.org/bugzilla/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the QA contact for the bug.
You are the assignee for the bug.



More information about the Ros-bugs mailing list