[ros-dev] Re: [ros-svn] [ion] 12738: Fix KeRaiseUserException and
rename Object Information Structure
ionucu at videotron.ca
Mon Jan 3 13:00:22 CET 2005
Eric Kohl wrote:
> ion at svn.reactos.com schrieb:
>> Fix KeRaiseUserException and rename Object Information Structure
> Please explain why you renamed the DIRECTORY_BASIC_INFORMATION
> structure to OBJECT_DIRECTORY_INFORMATION?
Because <OBJECT>_<CLASS>_INFORMATION applies to NtQuery calls where
there are actually multiple classes you can query. You don't query
NtDirectoryObject with an Information class, so
OBJECT_DIRECTORY_INFORMATION makes more sense. I originally wanted to
rename it to OBJECT_DIRECTORY_BASIC_INFORMATION, because DIRECTORY was
misleading, but then I noticed there was no info-class, so I removed the
BASIC. A Google search revealed someone else also had the same name.
> All publicly available sources call it DIRECTORY_BASIC_INFORMATION
I've found that only Bo's NTIFS.H calls it like that, while the other
name not only makes more sense, but is also referenced on NTDEV/NTFSD,
which is a more high-calibre place of information.
> so I think there is no need to rename it.
Does it break anything? Have you wasted time on it? If anything, I might
have done a useless renaming if you don't agree with it, but I don't
think it cost you any work.
> Please revert that modification because you are replacing a well-known
> structure by an unknown one.
Due to my points above, I don't think reverting is necessary, because it
is not unknown, and makes more sense. If you feel strongly against this,
you are free to rename it to what you want.
More information about the Ros-dev