[ros-dev] Assertion in /objects/dc.c

dolphin_ at gmx.net dolphin_ at gmx.net
Tue Mar 8 18:37:10 CET 2005


Hi!

I tried your changes, but it still doesn't work for me. I did a full rebuild 
(make clean, make, make bootcd) and burned the new image to CD and installed 
everything new to a newly formated hdd.
It stops with the same Assertion as it did before. Qemu is still not working 
too. The LiveCD however is working/booting though without problems.

I don't know if the setup uses 16 color VGA mode to complete the 
installation (it crashes when it first loads ReactOS and normally should 
show the Setup-Wizard).

Best regards,

    Dolphin



----- Original Message ----- 
From: "Ge van Geldorp" <gvg at reactos.com>
To: "'ReactOS Development List'" <ros-dev at reactos.com>
Sent: Tuesday, March 08, 2005 12:40 PM
Subject: RE: [ros-dev] Assertion in /objects/dc.c


>> From: dolphin_ at gmx.net
>>
>> At the first reboot after installation, I get the
>> following Assertion (cut from debug output):
>>
>> Assertion 'NewDC->DMW.dmBitsPerPel ==
> BitsPerFormat(SurfObj->iBitmapFormat)'
>> failed at objects/dc.c line 808
>>
>> I guess this error has something to do with the latest changes.
>> Perhaps someone can verify/fix this (GvG ?).
>
> Yes, this is definitely a problem I introduced. Are you using the 16 color
> VGA driver? If so (poor thing!), it should be fixed now (rev 13873).
>
> Gé van Geldorp.
>
>
> _______________________________________________
> Ros-dev mailing list
> Ros-dev at reactos.com
> http://reactos.com:8080/mailman/listinfo/ros-dev
> 



More information about the Ros-dev mailing list