[ros-dev] GPLv3 Migration - flamewar warning

Klemens Friedl frik85 at gmail.com
Tue Jul 3 21:21:50 CEST 2007


For the sake of completeness ...

"Is GPLv3 compatible with GPLv2?

No. Some of the requirements in GPLv3, such as the requirement to
provide Installation Information, do not exist in GPLv2. As a result,
the licenses are not compatible: if you tried to combine code released
under both these licenses, you would violate section 6 of GPLv2.

However, if code is released under GPL "version 2 or later," that is
compatible with GPLv3 because GPLv3 is one of the options it permits."

-- http://www.gnu.org/licenses/gpl-faq.html#v2v3Compatibility


More information about the Ros-dev mailing list