Sorry but these kinds of fixes are not &quot;readability fixes&quot;, in fact they make things more obtuse.<div><br></div><div>(*MdlPages &lt;&lt; PAGE_SHIFT)) could be interpreted as</div><div><br></div><div>*(MdlPages &lt;&lt; PAGE_SHIFT).</div>

<div><br></div><div>while</div><div><br></div><div>((*MdlPages) &lt;&lt; PAGE_SHIFT)</div><div><br></div><div>Makes it clear what is happening.</div><div><br></div><div>In general, all operations affecting the contents of a *dereference should be in parens.</div>

<div><br clear="all">Best regards,<br>Alex Ionescu<br>
<br><br><div class="gmail_quote">On Sun, Sep 11, 2011 at 7:47 AM,  <span dir="ltr">&lt;<a href="mailto:tfaber@svn.reactos.org">tfaber@svn.reactos.org</a>&gt;</span> wrote:<br><blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex;">

<div id=":3hw">-                                  ((*MdlPages) &lt;&lt; PAGE_SHIFT));<br>
+                                  (*MdlPages &lt;&lt; PAGE_SHIFT));</div></blockquote></div><br></div>