Forum update

ReactOS related news

Moderator: Moderator Team

Post Reply
Z98
Release Engineer
Posts: 3379
Joined: Tue May 02, 2006 8:16 pm
Contact:

Forum update

Post by Z98 » Mon May 26, 2008 1:10 am

After a lot of complaining by users about various things, the forum has been updated to phpbb3. Besides a minor problem with integration into the CMS and will be fixed shortly, which by the way doesn't stop anyone from using the forum, we're good to go. With bb3, people posting in the Asian language subforums should be able to use characters in the subject title now. Let us know if that's not the case. Posts from before the upgrade will still look garbled.

Feel free to report any problems you may encounter through one of the project contact methods.

Reacter
Posts: 326
Joined: Tue Feb 06, 2007 9:57 pm
Location: Tornado Alley

Re: Forum update

Post by Reacter » Mon May 26, 2008 6:30 am

Great job guys, once again you pull this off, and nothing happens to the server. I shouldn't say that, but ... ohh well.

Radhad
Posts: 605
Joined: Wed Apr 12, 2006 5:09 pm
Contact:

Re: Forum update

Post by Radhad » Mon May 26, 2008 8:23 am

It looks a bit ugly to me - I cannot see where are new posts or not! Hope you will fix that. Also there is no breadcrumb navi at the top.

preston
Developer
Posts: 272
Joined: Wed Sep 27, 2006 8:19 pm
Location: Prague, Czech Republic

Re: Forum update

Post by preston » Mon May 26, 2008 9:47 am

good job!

only one things bugs me.. why is the author info on the right side? can't we just follow the crowd and have it on the left side asi it was in the previous version (and as it is everywhere esle)? I don't see any advantages of this new layout it only makes me disoriented :(

cppm
Posts: 289
Joined: Wed May 02, 2007 10:03 pm

Re: Forum update

Post by cppm » Mon May 26, 2008 12:52 pm

I take it that the fact it looks completely out of wack with everything else is partly what is meant by "a minor problem with integration with the CMS", i which case I look forward to the forums reacquiring their RosCMS look 'n' feel :P

But that aside.... great work guys :D

michael79

Re: Forum update

Post by michael79 » Mon May 26, 2008 3:25 pm

I really preferred the old forum.

Z98
Release Engineer
Posts: 3379
Joined: Tue May 02, 2006 8:16 pm
Contact:

Re: Forum update

Post by Z98 » Mon May 26, 2008 5:03 pm

There are currently no plans to change the overall style of the board, though I do agree seeing new posts is a bit more difficult now. Breadcrumb navi will be back after I hound Fireball about uploading it. There was a real need to update the forum, since we actually have proper (at least I hope) unicode support now for non-Latin based languages.

LRN
Posts: 140
Joined: Thu Oct 25, 2007 4:19 pm

Re: Forum update

Post by LRN » Mon May 26, 2008 5:28 pm

We do. It's full-scale UTF-8 by default!

fred02
Posts: 551
Joined: Thu Nov 22, 2007 5:54 pm

Re: Forum update

Post by fred02 » Tue May 27, 2008 10:50 am

[quote="Radhad"]It looks a bit ugly to me - I cannot see where are new posts or not! Hope you will fix that. Also there is no breadcrumb navi at the top.[/quote]I think I got it: the red icon mean "new posts". (Although personally I think orange would be more appropriate with blue).
[quote="cppm"]I take it that the fact it looks completely out of wack with everything else is partly what is meant by "a minor problem with integration with the CMS"[/quote]It also seems a bit large in current layout.

But aside that, thank for the update, and have high expectation from the new forum once out of the transition period.

Edit: Humm, is the quoting working? And I don't see emoticons and formatting bar when editing. Is it transition period or my configuration?
Also avatars are currently disabled on purpose I guess.

Colin Finck
Developer
Posts: 108
Joined: Thu Oct 13, 2005 1:14 pm
Location: Germany
Contact:

Re: Forum update

Post by Colin Finck » Tue May 27, 2008 7:42 pm

BBCode should work again now. This was a bug in the phpBB conversion script.

Yes, avatars and file attachments are currently disabled on purpose.
From what I've heard, most developers prefer if the avatar setting stays disabled and I also don't think it would make sense to enable the attachment feature. Important attachments can go to the Bugzilla.

Best regards,

Colin Finck

elhoir
Test Team
Posts: 397
Joined: Thu Sep 13, 2007 7:01 pm
Location: Madrid, Spain
Contact:

Re: Forum update

Post by elhoir » Tue May 27, 2008 9:56 pm

another thing i have noticed is that when i click on a link, it does not open a new browser window (or tab when using Firefox or IE >=7), but it uses the current windows to show the target page.

Sinister
Posts: 4
Joined: Sat Apr 19, 2008 4:36 am

Re: Forum update

Post by Sinister » Tue Jun 10, 2008 6:22 am

I haven't checked back in a while (keep hoping for 0.3.5 :wink: ), but I like the new look here. Good work.

Post Reply

Who is online

Users browsing this forum: No registered users and 3 guests