Citrix XenServer and reactOS

Ask your support questions in here

Moderator: Moderator Team

Post Reply
PowerChaos
Posts: 3
Joined: Thu Nov 28, 2019 9:02 am
Location: inside php code

Citrix XenServer and reactOS

Post by PowerChaos » Thu Nov 28, 2019 9:23 am

hey all
not sure if it is a common problem , or just related to the citrix XenServer
i tried reactOS today and i want to put it on my hypervisor
it works perfectly in VMware, but as soon i want to install it on XenServer then it fails

lets reproduce the steps ( cant post screenshots at this moment , i will do that later )

i got the reactOS iso into my Iso libary (same as other iso's )
i create a new VM and i need to select a template
i got the choise out of differend linux flavors and some windows flavors , starting from windows 7 ( 32 bit )
There suggestion is to use the " Others" template if the version you want is not avaible in the template list
for windows 2003 and windows xp do the "others" template work ( also the windows 2008 template works )

for reactos it does not work ...

so after selecting a template and pressing the create vm button ( and mounting the iso ofcourse )then the reactOS installation starts
so far so good , it find the iso and it boots from the iso :D

now it start , it shows the blue screen with text on it and then a screen that says .... detecting hardware (or something like that , the pre post before install, maybe second or third install screen ? )

and it just stays stuck on there , never got past that screen

is there a way to get reactos running on Xenserver 8.0 or XNG-CP 8.0 ( same as xenserver , only open source )

Thank you
Greets from PowerChaos

karlexceed
Posts: 470
Joined: Thu Jan 10, 2013 6:17 pm
Contact:

Re: Citrix XenServer and reactOS

Post by karlexceed » Tue Dec 03, 2019 12:24 am

I just tried on XCP-NG 8 using the Server 2008 (32 bit) template and had no issues:
Image

What ISO are you using?

PowerChaos
Posts: 3
Joined: Thu Nov 28, 2019 9:02 am
Location: inside php code

Re: Citrix XenServer and reactOS

Post by PowerChaos » Tue Dec 03, 2019 2:47 am

I use the boot iso
In meantime there are some other problems not related to reactos
As on chat they asked to provide serial logs but as I am kinda buzzy dit I not got time to provide it

Today I tried it again but it also failt
It does works on unraid and qemu
Probably not reactos fault as when I install zorin os ( based on Ubuntu ) then I get a bios crash ( hp g8 node. Both servers )
And I dint even got to test reactos as the node keeps freezing after those crash

At this moment we are switching to proxmox as xng-cp is providing a lot of trouble ( because nas ? Ha mode ? Bios bug ? So many possible things )

So if it does work on xencenter then I am happy , then I know it’s not reactos but probably xenserver and the g8/g6 server ( dual cpu sock )

As soon proxmox is on it and I can test again and I let you know

Thank you for testing out
I do love the software and really want to use it :)

But at this moment I can not provide any feedback as My server is providing trouble

When I made this post everything was working ( got a lot of vps servers running on it at that time ). But at this point not even centos is working xd

Greets from PowerChaos

binarymaster
Posts: 285
Joined: Sun Nov 16, 2014 7:05 pm
Location: Russia, Moscow
Contact:

Re: Citrix XenServer and reactOS

Post by binarymaster » Tue Dec 03, 2019 4:30 pm

karlexceed wrote:
Tue Dec 03, 2019 12:24 am
What ISO are you using?
Too late answer. ;) We discussed this subject on Nov 28 in the chat: https://chat.reactos.org/reactos/pl/4o1 ... x7qjh9raqc

OP is using 0.4.12 instead of 0.4.14-dev, and it was USB problem.

karlexceed
Posts: 470
Joined: Thu Jan 10, 2013 6:17 pm
Contact:

Re: Citrix XenServer and reactOS

Post by karlexceed » Tue Dec 03, 2019 4:35 pm

binarymaster wrote:
Tue Dec 03, 2019 4:30 pm
it was USB problem
OF COURSE, lol

PowerChaos
Posts: 3
Joined: Thu Nov 28, 2019 9:02 am
Location: inside php code

Re: Citrix XenServer and reactOS

Post by PowerChaos » Tue Dec 03, 2019 5:07 pm

Thank you for solving this :)
I going try the latest nightly build

Greets from PowerChaos

Post Reply

Who is online

Users browsing this forum: Ahrefs [Bot] and 2 guests