Mouse and keyboard don't work (Install CD)

Ask your support questions in here

Moderator: Moderator Team

jfranks
Posts: 3
Joined: Thu Apr 24, 2014 3:06 am

Mouse and keyboard don't work (Install CD)

Post by jfranks » Thu Apr 24, 2014 3:48 am

Hi,
I tried installing from 0.3.16-ReactOS-REL.
The keyboard and mouse don't work on the 1st screen selecting language.

The machine is a Compaq Presario SR1215CL, 3000+ AMD Sempron, 512 MB RAM, 120GB HD.

Any thoughts about this?

regards,
Jeff Franks

Black_Fox
Posts: 1584
Joined: Fri Feb 15, 2008 9:44 pm
Location: Czechia

Re: Mouse and keyboard don't work (Install CD)

Post by Black_Fox » Thu Apr 24, 2014 9:56 am

Hi and welcome to the forums!

There are two things you can try. Maybe the keyboard and mouse/touchpad are internally connected over USB, so you could try to set USB to "Legacy" in BIOS.
Another option is, since the last official release has already gotten old and there were changes done to ReactOS since then, you could try the bleeding-edge trunk builds that have seen another 10 weeks of improvements.

justincase
Posts: 431
Joined: Sat Nov 15, 2008 4:13 pm

Re: Mouse and keyboard don't work (Install CD)

Post by justincase » Thu Apr 24, 2014 11:13 am

Black_Fox wrote:Maybe the keyboard and mouse/touchpad are internally connected over USB, so you could try to set USB to "Legacy" in BIOS.
Compaq Presario SR1215CL is a desktop PC with PS/2 mouse & keyboard ports.
So if you're using USB mouse & keyboard (and setting "Legacy USB" in BIOS doesn't fix it), perhaps you should try using the PS/2 ports (USB support is still a work in progress).
Black_Fox wrote:since the last official release has already gotten old and there were changes done to ReactOS since then
The releases are completely out of sync with current development, so they're out of date the day they're released.
The purpose of the releases is not for compatibility testing, but for newcomers to see approximately how much ReactOS has improved in the time since the previous release.
Thus please test with the trunk builds (as mentioned by Black_Fox).

And also since you're testing on physical hardware please feel free to add your system(s) and experiences to the hardware testing Wiki page.
I reserve the right to ignore any portion of any post if I deem it not constructive or likely to cause the discussion to degenerate.

jfranks
Posts: 3
Joined: Thu Apr 24, 2014 3:06 am

Re: Mouse and keyboard don't work (Install CD)

Post by jfranks » Thu Apr 24, 2014 11:57 pm

Thank you all for your insightful responses.

Switching to PC-2 for keyboard and mouse did not fix the issue.
However, setting the ROM-BIOS to disable plug-and-play allowed me to go through the install (using PC-2 devices).

The install could not find Wine Gecko and I gave permission to download it.
However, this failed because it could not find communication drivers for the ethernet device.

Is there a solution for that?

regards,
--Jeff Franks

Black_Fox
Posts: 1584
Joined: Fri Feb 15, 2008 9:44 pm
Location: Czechia

Re: Mouse and keyboard don't work (Install CD)

Post by Black_Fox » Fri Apr 25, 2014 1:04 am

You can actually skip (cancel) the Gecko download to proceed with the installation. If you don't have network drivers, it wouldn't be of use anyway. Also, you can download an internet browser later via ReactOS Application Manager.

jfranks
Posts: 3
Joined: Thu Apr 24, 2014 3:06 am

Re: Mouse and keyboard don't work (Install CD)

Post by jfranks » Fri Apr 25, 2014 5:55 am

I did cancel the Gecko download and completed the installation.

The problem is that the system is stand-alone without a network connection. I cannot reach the internet because of the missing network driver(s).

So, the question continues . . . Is there something I can do to fix this?

regards,
--Jeff Franks

Z98
Release Engineer
Posts: 3379
Joined: Tue May 02, 2006 8:16 pm
Contact:

Re: Mouse and keyboard don't work (Install CD)

Post by Z98 » Fri Apr 25, 2014 7:31 am

If you have a copy of the network driver, you can use it to install on ReactOS. USB is hit and miss and you might get it working, otherwise having CD-RWs helps if you need to burn things to get files onto the computer. A tester might also be able to tell you how to slipstream drivers on, I know that at one point this was possible.

erkinalp
Posts: 814
Joined: Sat Dec 20, 2008 5:55 pm

Re: Mouse and keyboard don't work (Install CD)

Post by erkinalp » Fri Apr 25, 2014 8:03 am

USB keyboards will not work in EFI CSM setups because of the lack of legacy USB. They will work when a proper USB driver is included.
-uses Ubuntu+GNOME 3 GNU/Linux
-likes Free (as in freedom) and Open Source Detergents
-favors open source of Windows 10 under GPL2

skris88
Posts: 4
Joined: Fri May 11, 2018 4:29 am

Re: Mouse and keyboard don't work (Install CD)

Post by skris88 » Fri May 11, 2018 4:32 am

It's now 4 years later. Any chance we can install this with a USB keyboard and mouse yet? THANKS!

EmuandCo
Developer
Posts: 4278
Joined: Sun Nov 28, 2004 7:52 pm
Location: Germany, Bavaria, Steinfeld
Contact:

Re: Mouse and keyboard don't work (Install CD)

Post by EmuandCo » Fri May 11, 2018 8:52 am

If you use vgal's USB stack, maybe
Image
ReactOS is still in alpha stage, meaning it is not feature-complete and is recommended only for evaluation and testing purposes.

skris88
Posts: 4
Joined: Fri May 11, 2018 4:29 am

Re: Mouse and keyboard don't work (Install CD)

Post by skris88 » Fri May 11, 2018 2:57 pm

EmuandCo wrote:If you use vgal's USB stack, maybe
Can I get instructions on how (what/where/etc) to add that into my Installation CR-ROM please? Hardly any PCs these days have PS/2 keyboard ports, let alone PS/2 keyboards (although I may have a USB to PS/2 adapter still lying around somewhere).

Thanks!

Cheers,

karlexceed
Posts: 434
Joined: Thu Jan 10, 2013 6:17 pm
Contact:

Re: Mouse and keyboard don't work (Install CD)

Post by karlexceed » Fri May 11, 2018 3:11 pm

You don't need to slipstream it yourself, just use one of the builds that have been made:

search.php?keywords=vgal+usb&terms=all& ... mit=Search

http://vgal.ru.com/reactos-0-4-7-2-new-usb/

middings
Posts: 991
Joined: Tue May 07, 2013 9:18 pm
Location: California, USA

Re: Mouse and keyboard don't work (Install CD)

Post by middings » Sat May 12, 2018 8:22 pm

skris88 wrote:(...I may have a USB to PS/2 adapter still lying around somewhere).
Unfortunately, using an adapter will not overcome your present difficulty. You will still be using the USB port. The problem exists in ReactOS's routines that manage your PC's USB ports and user-installable USB drivers.

skris88
Posts: 4
Joined: Fri May 11, 2018 4:29 am

Re: Mouse and keyboard don't work (Install CD)

Post by skris88 » Sun May 13, 2018 1:00 pm

karlexceed wrote:You don't need to slipstream it yourself, just use one of the builds that have been made:

search.php?keywords=vgal+usb&terms=all& ... mit=Search

http://vgal.ru.com/reactos-0-4-7-2-new-usb/

Thanks for the links. Am downloading http://vgal.ru.com/reactos-0-4-7-2-new-usb/ now. Fingers crossed! :)

skris88
Posts: 4
Joined: Fri May 11, 2018 4:29 am

Re: Mouse and keyboard don't work (Install CD)

Post by skris88 » Sun May 13, 2018 2:23 pm

Release 0.4.8 "works" (but my USB mouse and keyboard are not recognized).

The 0.4.7 release (with USB-slipstreamed) hangs. :(

I restarted it in (Screen) mode and it hangs at one spot, seems to be related to USB.
There are several messages repeated....
(../drivers/usb/usbport/endpointc:791) USBPORT_OpenPipe: DeviceHandle - B7038F
0.8, FdoDevice - B7080030, Pipehandle - B7038508
(../drivers/usb/usbport/endpointc:791) USBPORT_OpenPipe: DeviceHandle - B7037F
0.8, FdoDevice - B7080030, Pipehandle - B7037F10
(../drivers/usb/usbport/endpointc:791) USBPORT_OpenPipe: DeviceHandle - B7037F
0.8, FdoDevice - B7080030, Pipehandle - B7037578
(../drivers/usb/usbport/endpointc:791) USBPORT_OpenPipe: DeviceHandle - B73E08
0.8, FdoDevice - B70E4030, Pipehandle - B703E0838

and it hangs right there.

Can anyone suggest whether "B7080030" is a set of 4 USB ports and "B70E4030" the next set of 4 USB ports (inside or outside), and hjow I might find out which one(s) to disable?

I tried turning off my Dell Dimension E520 PC's "Boot From USB" feature in the BIOS and also disabled "rear USB ports" and am using only the front two (for my combo mouse/keyboard). But it didn't help.

Any ideas will be most appreciated.

Thanks!

Post Reply

Who is online

Users browsing this forum: Baidu [Spider], Exabot [Bot], Istella [Bot] and 1 guest