Page 1 of 1

Blue Screen crash on VirtualBox

Posted: Fri Feb 03, 2017 1:46 pm
by ab396356
I have installed ReactOS-0.4.3-iso in an Oracle VirtualBox virtual machine but after installing devices and restarting, it always dies with a Blue Screen.

Virtual machine settings:
  • 512 MB base memory
  • 24 MB video memory
  • 1 GB VHD (Virtual Hard Disk)
Technical information:

Code: Select all

*** STOP: 0xC0000218 (0x00060010,0x00000000,0x00000000,0x00000000)
Screenshot:
Image

Re: Blue Screen crash on VirtualBox

Posted: Fri Feb 03, 2017 2:14 pm
by dizt3mp3r

Re: Blue Screen crash on VirtualBox

Posted: Fri Feb 03, 2017 5:40 pm
by EmuandCo
Giving us memory and stuff is a nice 1st step, but what OS did you select as VM base? Which Version of VBOX is that?

Re: Blue Screen crash on VirtualBox

Posted: Fri Feb 03, 2017 9:24 pm
by ab396356
EmuandCo wrote:Giving us memory and stuff is a nice 1st step, but what OS did you select as VM base? Which Version of VBOX is that?

Code: Select all

Type: Microsoft Windows
Version: Windows 2003 (32-bit)

VirtualBox Graphical User Interface
Version 5.1.14 r112924 (Qt5.6.2)
I also tried using "Windows XP (32-bit)" but had the same crash. Specify what settings the VM should have for best compatibility with ReactOS.

And on the topic of the error message above: what does it mean? What is the reason for the crash?

Re: Blue Screen crash on VirtualBox

Posted: Sat Feb 04, 2017 12:29 am
by PurpleGurl
Assuming this error works like on Windows, it has to do with a registry hive not getting loaded. It could be absent, corrupt, or not writable.

https://support.microsoft.com/en-us/hel ... or-message

So, you could be using a corrupted hard drive, or maybe this is a problem with the drivers or registry handling code in ROS.

Re: Blue Screen crash on VirtualBox

Posted: Sat Feb 04, 2017 1:53 pm
by ab396356
PurpleGurl wrote:Assuming this error works like on Windows, it was to do with a registry hive not getting loaded. It could be absent, corrupt, or not writable.
You are right. Upon reinstalling (all defaults and quick format), I now get an error "Importing binary hive failed!" as seen in the screenshot below:

Image
PurpleGurl wrote:So, you could be using a corrupted hard drive, or maybe this is a problem with the drivers or registry handling code in ROS.
I am reinstalling on a 1 GB VHD which I reformat every time (first time "long" format, since then "quick"). What can I do now to fix this, or what settings should I change in the VM?

If developers need more information for debugging, let me know how to provide it. Also, since you are distributing the .ISO images zipped, consider putting the .MD5 checksum of the image in that .ZIP file while you're at it.

Re: Blue Screen crash on VirtualBox

Posted: Sat Feb 04, 2017 8:43 pm
by MadWolf
hi
do you know that testing ReactOS-0.4.3 is pointless you are better testing Daily Builds https://reactos.org/getbuilds/ or 0.4.4 viewtopic.php?f=2&t=16220

Re: Blue Screen crash on VirtualBox

Posted: Mon May 22, 2017 5:47 pm
by AdrienTD
Hi,
I used the ReactOS 0.4.5 Boot CD on VirtualBox 4.x.x and 5.1.22 and I get exactly the same thing stated in this thread.
The first time I installed ReactOS on the hard disk, then when booting the hard disk I got the graphical OOBE wizard (where I set the time, set the name and password of accounts, ...). The wizard finished and asked to reboot. But when I boot the harddisk again:
  • I get a BSOD with stop error 0xC0000218 (0x00060010, 0, 0, 0). When I run ReactOS in debug mode and with the COM port enabled I saw that an operation with the hive has failed (it checked whetever some numbers were what ReactOS expected), then it did an int3 software breakpoint and went into a kernel debugger.
  • I installed ReactOS again on a new harddrive. But after the OOBE, instead of a BSOD, the bootloader displays the message: Importing binary hive failed!
I suppose that after the first boot of ReactOS, the hive gets somehow corrupted. When I first boot ReactOS it works and displays the OOBE app, but when booting a second time it fails loading the hive.
Not sure if this is related with VirtualBox or maybe with the fact my CPU doesn't support hardware virtualization?
I am fully able to boot the ReactOS 0.4.4 Live CD, maybe because the Live CD already has an hive that works?
Hopefully there will be a fix because I would like to use the VirtualBox Guest Additions that I don't know how to install on a Live CD. :|

Re: Blue Screen crash on VirtualBox

Posted: Mon May 22, 2017 8:17 pm
by romulo27
for me it works perfect with "other windows 64 bit" (i put 64 bit even if it isnt 64 bit just for sure, and it works) still i use vmware, because my virtualbox is messed up after i installed a vpn service, and it now doesnt see my ethernet driver, just my vpn driver

Re: Blue Screen crash on VirtualBox

Posted: Mon Feb 26, 2018 3:06 pm
by gdsotirov
I had the same problem with ReactOS 0.4.8-RC on ESXi 5.5, but after moving the virtual machine on another disk and creating new virtual disk the problem is gone.

Re: Blue Screen crash on VirtualBox

Posted: Fri Mar 08, 2019 5:47 am
by kotleopold140
Oh no!!!
I installed this operating system version 0.4.10 on real hardware and after installation, at startup, the same blue screen of death appears as in the photo above. What to do?

Re: Blue Screen crash on VirtualBox

Posted: Fri Mar 08, 2019 10:22 am
by EmuandCo
It would be quite helpful to tell us WHICH real hardware was used...

Re: Blue Screen crash on VirtualBox

Posted: Fri Mar 08, 2019 5:01 pm
by PurpleGurl
I'd also try one of the latest "nightly" builds.

Also, since you reopened a thread someone else started, I'd double-check to see if the BSOD codes are the same. Just because you have a blue screen, it doesn't mean you are both having the same error.

It is better to start your own thread and not reopen an old one that someone else started for what might be a different problem.

Also, you might want to check to see if the same Stop error is in Jira (our bug tracker). If not, you can put it there.

Re: Blue Screen crash on VirtualBox

Posted: Thu May 23, 2019 2:31 pm
by simontnms115
I have same issue, let me know if any solution found.

Re: Blue Screen crash on VirtualBox

Posted: Thu May 23, 2019 9:07 pm
by binarymaster
simontnms115 wrote:
Thu May 23, 2019 2:31 pm
I have same issue, let me know if any solution found.
What are your VM settings?