Question about Audio !

Ask your support questions in here

Moderator: Moderator Team

Post Reply
Adcock
Posts: 231
Joined: Thu Jul 07, 2016 5:37 pm

Question about Audio !

Post by Adcock » Thu Dec 07, 2017 4:09 pm

Hello Reactors,
What is the condition of the audio system of ReactOS ?

When I install ReactOS on VirtualBox, I don't get the audio system to work automatically.

I use AC97 audio driver on VirtualBox.
With Windows XP audio works automatically on VirtualBox.
Shouldn't it be the same with ReactOS ?
Is there something I am missing ?
Open Your Windows To Freedom

EmuandCo
Developer
Posts: 4329
Joined: Sun Nov 28, 2004 7:52 pm
Location: Germany, Bavaria, Steinfeld
Contact:

Re: Question about Audio !

Post by EmuandCo » Thu Dec 07, 2017 8:44 pm

Well, seems like you forgot that ReactOS is in Alpha Stadium I would say... After all these weeks...
Image
ReactOS is still in alpha stage, meaning it is not feature-complete and is recommended only for evaluation and testing purposes.

Konata
Posts: 391
Joined: Sun Apr 20, 2014 8:54 pm

Re: Question about Audio !

Post by Konata » Fri Dec 08, 2017 4:30 am

Sound in general in ReactOS is horribly incomplete right now, last I checked it only supported one specific bitrate or something. After sound is actually complete the team can probably begin to actually make it work out of the box.

Adcock
Posts: 231
Joined: Thu Jul 07, 2016 5:37 pm

Re: Question about Audio !

Post by Adcock » Fri Dec 08, 2017 5:34 am

Thanks for help. :)
Open Your Windows To Freedom

matthiasbasler
Posts: 35
Joined: Sun Sep 18, 2016 9:53 am

Re: Question about Audio !

Post by matthiasbasler » Fri Feb 09, 2018 8:11 pm

Hi Adcock,

I found sound working in VirtualBox with the AC-97 driver and documented this on my How-To page here:
https://www.reactos.org/wiki/User:Matthiasbasler

Don't expect sound on real hardware, though.

Post Reply

Who is online

Users browsing this forum: Google [Bot] and 2 guests