Copy file returns "Error writing destination"

Ask your support questions in here

Moderator: Moderator Team

Post Reply
Posts: 10
Joined: Mon May 14, 2012 12:21 pm
Location: Ontario Canada

Copy file returns "Error writing destination"

Post by SteveB » Tue Jan 23, 2018 4:11 pm

Hosted in a QEMU VM on Centos 6.7
VM Config
CPU(s) 1
Arch: AMD FX
RAM Total : 2GB
RAM Free : 1.7GB
HDD Total : 8GB
HDD Free : 4.59GB

Using the shell and the copy command to duplicate a rather large (680 MB) file from a virtual CD ROM to the C: drive.
The C: drive has 4+GB of free space available.
On issuing the command the copy appears to be going well, then after a few seconds it fails with the messages

"Error writing destination!
Error writing destination!
ERROR_NOT_ENOUGH_MEMORY - Not enough storage is available to process this command. 0 file(s) copied"

What caught my eye was the "NOT_ENOUGH_MEMORY", as opposed to "NOT_ENOUGH_DISK_SPACE". That made me think that the copy command might be trying to load the complete 680MB file into RAM before it begins writing to disc. This shouldn't be a problem with 1.7GB of free RAM. Can someone else give this kind of operation a try and confirm the behaviour?


I also tried running the exe directly from the CD ROM and it failed with a "file is corrupt".

When performing either of these tasks on Windows 7 hosted in a VM using the same virtual CD ROM neither of these errors occured.

Same error occurs with xcopy

Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest