RosBE 2.1.2 - zlib is missing

Ask your support questions in here

Moderator: Moderator Team

Post Reply
Fraizeraust
Posts: 221
Joined: Thu Jan 05, 2017 11:46 am
Location: Italy
Contact:

RosBE 2.1.2 - zlib is missing

Post by Fraizeraust » Wed Apr 25, 2018 10:16 am

The title is self-explanatory, the RosBE Shell installer fails to continue because of the lack of zlib but I do already have the required packages... Here are the installed zlib libs as follows:

Code: Select all

zlib1g zlib1g-dev zlib1g-dev:i386 zlib1g:i386 zlibc
The error output:

Code: Select all

Checking for the needed tools...
Checking for as... OK
Checking for bison... OK
Checking for flex... OK
Checking for gcc... OK
Checking for g++... OK
Checking for grep... OK
Checking for makeinfo... OK
Checking for python... OK
Checking for GNU Make... OK
Checking for zlib... MISSING
At least one needed tool is missing, aborted!
I run Lubuntu 16.04.4 LTS 64-bit on my machine.

oldman
Posts: 1012
Joined: Sun Dec 20, 2009 1:23 pm

Re: RosBE 2.1.2 - zlib is missing

Post by oldman » Wed Apr 25, 2018 1:49 pm

I seem to just remember having the same problem.
This (below) is a small portion of a script that I have put on my wiki page (Layman's guide). Which I have altered and made it a simple test.
Copy and paste it into a text editor and save it somewhere with the file extension of .sh, then chmod +x the file, then run it. If it shows that zlib is missing, then you will need to install pkg-config or whatever package contains pkg-config. Then you should find that RosBE finds zlib.

Code: Select all

  if pkg-config --exists zlib;
  then
    printf "found zlib"
  else
    printf "Cannot find zlib"
  fi
Let me know how you get on.
Please keep the Windows classic (9x/2000) look and feel.
The layman's guides to - debugging - bug reporting - compiling - with some complementary scripts.
They may help you with a problem, so do have a look at them.

Fraizeraust
Posts: 221
Joined: Thu Jan 05, 2017 11:46 am
Location: Italy
Contact:

Re: RosBE 2.1.2 - zlib is missing

Post by Fraizeraust » Wed Apr 25, 2018 3:01 pm

Thank you for the response, oldman.

I have tested your Shell script and the culprit was because of pkg-config could not be found. I have installed it and now everything is fine. Quite strange how zlib depends upon pkg-config....

Thank you for your help, regardless!

ThFabba
Developer
Posts: 171
Joined: Sun Jul 11, 2010 11:39 am

Re: RosBE 2.1.2 - zlib is missing

Post by ThFabba » Wed Apr 25, 2018 6:17 pm

It's a bug in RosBE. It uses pkg-config to find zlib but it doesn't check whether pkg-config exists first, so it doesn't tell you that that's what's missing.

There's a Jira ticket about it: https://jira.reactos.org/browse/ROSBE-93
We should hopefully have a new RosBE release at some point.

MadWolf
Posts: 524
Joined: Sat Dec 31, 2005 4:19 am
Contact:

Re: RosBE 2.1.2 - zlib is missing

Post by MadWolf » Thu Apr 26, 2018 1:14 am

hi
i installed zlib and then commented out the line

Code: Select all

    rs_needed_libs="zlib"

in the RosBE-Builder.sh

edit thanks that worked

Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest