ROS 4.10/4.11 hang on boot after 'Verifying the file system'

Ask your support questions in here

Moderator: Moderator Team

Walt
Posts: 20
Joined: Tue Sep 04, 2018 1:39 am

Re: ROS 4.10/4.11 hang on boot after 'Verifying the file system'

Post by Walt » Tue Sep 18, 2018 1:42 am

Scandisk from a floppy. It REALLY doesn't like that HDD and if allowed will 'fix' all kinds of things. As does ROS itself, at least sometimes, if booted from the HDD following the install. Sometimes you get a blank screen after the boot, sometimes a couple screenfulls of we're checking your disk, fixing this, fixing that ... But the fixes basically suck: AIR one is to cut the length of pagefile.sys to zero.

A couple days ago when installing ROS I told it to delete the existing partition and then create a new one of 1 Gig, doing a real format of that. Since then I've just had it do a quick format.

This HDD HAD a working copy of XP on it; it was the backup copy for another machine. When a disk throws errors I throw it out. However I suppose I could format and scan it using the XP tools. Doing just the 1 Gig wouldn't take very long.

Walt
Posts: 20
Joined: Tue Sep 04, 2018 1:39 am

Re: ROS 4.10/4.11 hang on boot after 'Verifying the file system'

Post by Walt » Tue Sep 18, 2018 5:22 am

If I do a real format of the partition outside of ROS then boot the system CD and do the install in the usual way BUT WITHOUT installing the MBR then I have a disk that SCANDISK pretty much likes: It complains about the amount of free space being incorrectly reported but if allowed to fix that, seems to be okay. Looked at under Win XP it seems fine as far as I can tell without being able to execute anything. File structures work, files that can be looked at with notepad look fine, etc.

There are combinations I haven't tried -- most obviously a real format IN ROS install but exiting without installing an MBR but not much payoff there I think. Writing the MBR seems to be what trashes the file system.

Unfortunately I can't think of a way around this. MBRs (etc.) tend to be system specific and the option to install it to a floppy does not appear to be coded -- if you try it says you need to put a formatted floppy in the drive no matter what's already in there. There IS an option to just install a VBR -- I'm guessing that's an MBR for use in a virtual machine -- but I'm not going to set up a VM.

Suggestions?

oldman
Posts: 1072
Joined: Sun Dec 20, 2009 1:23 pm

Re: ROS 4.10/4.11 hang on boot after 'Verifying the file system'

Post by oldman » Tue Sep 18, 2018 9:56 am

Walt wrote:
Tue Sep 18, 2018 5:22 am
Suggestions?
I have used Windows to format the hard drive to fat32 in the past, so you could use Windows fdisk to clear all partitons (assuming there is nothing else of importance on the hard drive) and create a 20 GB fat32 partition, then format it, even do a scandisk on it. When you come to installing ReactOS on the partition, select keep the existing file system and at the end select MBR for the boot record.

I hope that works for you.
Please keep the Windows classic (9x/2000) look and feel.
The layman's guides to - debugging - bug reporting - compiling - with some complementary scripts.
They may help you with a problem, so do have a look at them.

karlexceed
Posts: 467
Joined: Thu Jan 10, 2013 6:17 pm
Contact:

Re: ROS 4.10/4.11 hang on boot after 'Verifying the file system'

Post by karlexceed » Tue Sep 18, 2018 3:22 pm

Walt wrote:
Tue Sep 18, 2018 1:42 am
Scandisk from a floppy.
Scandisk is a filesystem diagnostic/repair tool - have you tried an HDD diagnostic like SeaTools or Data Lifeguard Diagnostic to test the actual disk itself?

Also - when installing ROS, I've never manually created the partition structure. If there was an existing structure, I use the tools in the installer to remove all partitions and then just tell the installer to continue and automatically create the partitions itself. Have you tried this method?

Walt
Posts: 20
Joined: Tue Sep 04, 2018 1:39 am

Re: ROS 4.10/4.11 hang on boot after 'Verifying the file system'

Post by Walt » Wed Sep 19, 2018 3:22 am

This appears to be CORE14990, although it's surely a regression. I have updated there. Gonna go back & see if I can get an idea when it showed up. It doesn't seem to be very recent and I wonder if it occurs only on real machine installs or even some less common condition.

"Scandisk is a filesystem diagnostic/repair tool - have you tried an HDD diagnostic like SeaTools or Data Lifeguard Diagnostic to test the actual disk itself?"

No -- just scandisk. I have, however reproduced this problem (with variations of flavor) on three different HDDs, all known to be working normally in the recent past.

"Also - when installing ROS, I've never manually created the partition structure. If there was an existing structure, I use the tools in the installer to remove all partitions and then just tell the installer to continue and automatically create the partitions itself. Have you tried this method?"

I have tried that but the structure that's there now is the one ROS created. I do a real format every time, though, as the FAT seems to be trashed and disks that are quick formatted become VERY strange -- as in two copies of same name file, cross-linked chains, etc.

Walt
Posts: 20
Joined: Tue Sep 04, 2018 1:39 am

Re: ROS 4.10/4.11 hang on boot after 'Verifying the file system'

Post by Walt » Wed Sep 19, 2018 10:32 pm

I was wrong: The disk is already damaged (per bootable scandisk) if you stop BEFORE the MBR is written. On a retry -- 5 gig partition, real format -- it reported that several files and subfolders of system32/config/ were damaged. Next time I tried -- exact same setup & procedure -- 'amount of free space of drive C is being reported incorrectly.' Third, fourth & fifth times -- 'amount of free space ...' again.

Sixth time I allowed ROS to write the MBR and boot for the second phase. The last thing on the ROS screen is 'Verifying the file system ...' The debug log is:

Code: Select all

=~=~=~=~=~=~=~=~=~=~=~= PuTTY log 2018.09.19 16:21:09 =~=~=~=~=~=~=~=~=~=~=~=
(ntoskrnl/kd/kdio.c:105) -----------------------------------------------------
(ntoskrnl/kd/kdio.c:106) ReactOS 0.4.11-dev (Build 20180918-0.4.11-dev-181-gda73c81) (Commit da73c812598b56d137632f033afa51a68f022ca4)
(ntoskrnl/kd/kdio.c:107) 1 System Processor [2047 MB Memory]
(ntoskrnl/kd/kdio.c:108) Command Line: DEBUG DEBUGPORT=COM1 BAUDRATE=115200 SOS
(ntoskrnl/kd/kdio.c:109) ARC Paths: multi(0)disk(0)rdisk(0)partition(1) \ multi(0)disk(0)rdisk(0)partition(1) \ReactOS\
(ntoskrnl/ke/i386/cpu.c:450) Supported CPU features : KF_V86_VIS KF_RDTSC KF_CR4 KF_CMOV KF_GLOBAL_PAGE KF_LARGE_PAGE KF_MTRR KF_CMPXCHG8B KF_MMX KF_WORKING_PTE KF_PAT KF_FXSR KF_FAST_SYSCALL KF_XMMI   KF_XMMI64 KF_DTS   
(ntoskrnl/ke/i386/cpu.c:722) Prefetch Cache: 64 bytes	L2 Cache: 1048576 bytes	L2 Cache Line: 64 bytes	L2 Cache Associativity: 8
(hal/halx86/acpi/halacpi.c:782) ACPI Timer at: 808h (EXT: 0)
(hal/halx86/acpi/halacpi.c:533) ACPI Boot table found, but not supported!
(hal/halx86/acpi/halacpi.c:890) ACPI 2.0 Detected. Tables: [RSDT] [FACP] [BOOT] 
(ntoskrnl/mm/ARM3/mminit.c:1452) HAL I/O Mapping at FFFE0000 is unsafe
(ntoskrnl/mm/mminit.c:131)           0x80000000 - 0x83400000	Boot Loaded Image
(ntoskrnl/mm/mminit.c:135)           0xB0000000 - 0xB0DFE000	PFN Database
(ntoskrnl/mm/mminit.c:139)           0xB0DFE000 - 0xB4DB6000	ARM3 Non Paged Pool
(ntoskrnl/mm/mminit.c:143)           0xB9400000 - 0xBB400000	System View Space
(ntoskrnl/mm/mminit.c:147)           0xBB400000 - 0xC0000000	Session Space
(ntoskrnl/mm/mminit.c:150)           0xC0000000 - 0xC03FFFFF	Page Tables
(ntoskrnl/mm/mminit.c:153)           0xC0300000 - 0xC0300FFF	Page Directories
(ntoskrnl/mm/mminit.c:156)           0xC0400000 - 0xC07FFFFF	Hyperspace
(ntoskrnl/mm/mminit.c:159)           0xC1000000 - 0xE0FFFFFF	System Cache
(ntoskrnl/mm/mminit.c:163)           0xE1000000 - 0xECC00000	ARM3 Paged Pool
(ntoskrnl/mm/mminit.c:166)           0xECC00000 - 0xF7BE0000	System PTE Space
(ntoskrnl/mm/mminit.c:169)           0xF7BE0000 - 0xFFBE0000	Non Paged Pool Expansion PTE Space
(ntoskrnl/config/cmcheck.c:25) CmCheckRegistry(0xB4D55008, 2) is UNIMPLEMENTED!
ACPI Compatible Eisa/Isa HAL Detected
(sdk/lib/rtl/image.c:172) Invalid base address: 00000000
(ntoskrnl/io/iomgr/driver.c:1585) '\Driver\SACDRV' initialization failed, status (0xc0000037)
(ntoskrnl/io/iomgr/driver.c:64) Deleting driver object '\Driver\SACDRV'
(drivers/storage/scsiport/scsiport.c:5859) ZwOpenKey() failed with Status=0xC0000034
(hal/halx86/legacy/bus/pcibus.c:727) WARNING: PCI Slot Resource Assignment is FOOBAR
(ntoskrnl/io/iomgr/iorsrce.c:874) IoReportResourceUsage is halfplemented!
(ntoskrnl/io/iomgr/iorsrce.c:874) IoReportResourceUsage is halfplemented!
(ntoskrnl/io/iomgr/driver.c:1585) '\Driver\BUSLOGIC' initialization failed, status (0xc00000c0)
(ntoskrnl/io/iomgr/driver.c:64) Deleting driver object '\Driver\BUSLOGIC'
(drivers/filesystems/fastfat/iface.c:161) FastFAT KDBG extension registered: yes
(drivers/ksfilter/swenum/swenum.c:428) SWENUM loaded
(drivers/bus/acpi/buspdo.c:833) Failed to find a bus number
(ntoskrnl/mm/ARM3/sysldr.c:3037) ZwOpenFile failed for '\SystemRoot\system32\drivers\vbemp.sys' with status 0xc000003a
(ntoskrnl/mm/ARM3/sysldr.c:3037) ZwOpenFile failed for '\SystemRoot\system32\drivers\vbemp.sys' with status 0xc000003a
(ntoskrnl/mm/ARM3/sysldr.c:3037) ZwOpenFile failed for '\SystemRoot\System32\DRIVERS\i8042prt.sys' with status 0xc000003a
(ntoskrnl/mm/ARM3/sysldr.c:3037) ZwOpenFile failed for '\SystemRoot\System32\DRIVERS\i8042prt.sys' with status 0xc000003a
(ntoskrnl/mm/ARM3/sysldr.c:3037) ZwOpenFile failed for '\SystemRoot\system32\drivers\vbemp.sys' with status 0xc000003a
(ntoskrnl/mm/ARM3/sysldr.c:3037) ZwOpenFile failed for '\SystemRoot\System32\DRIVERS\i8042prt.sys' with status 0xc000003a
(ntoskrnl/mm/ARM3/sysldr.c:3037) ZwOpenFile failed for '\SystemRoot\System32\DRIVERS\i8042prt.sys' with status 0xc000003a
(ntoskrnl/io/iomgr/iorsrce.c:725) Failed to open symlink \Device\Harddisk0\Partition1, Status=c0000024
(ntoskrnl/cc/pin.c:81) Mapping/pinning with no read not implemented. Forcing read, might fail if wait not allowed
(ntoskrnl/mm/ARM3/sysldr.c:176) Loading: \SystemRoot\system32\drivers\vbemp.sys at F7756000 with c pages
(ntoskrnl/mm/ARM3/sysldr.c:176) Loading: \SystemRoot\system32\drivers\videoprt.sys at F7730000 with 26 pages
(ntoskrnl/io/pnpmgr/pnpinit.c:325) IopOpenRegistryKeyEx() failed for '{4D36E968-E325-11CE-BFC1-08002BE10318}' with status 0xc0000034
WARNING:  ExUuidCreate at ntoskrnl/ex/uuid.c:305 is UNIMPLEMENTED!
(win32ss/drivers/videoprt/registry.c:312) Failed to open device software key. Status 0xc0000034
(ntoskrnl/mm/ARM3/sysldr.c:176) Loading: \SystemRoot\System32\DRIVERS\i8042prt.sys at F7714000 with 1c pages
(drivers/input/i8042prt/hwhacks.c:229) SMBiosTables HACK, see CORE-14867
(ntoskrnl/mm/ARM3/sysldr.c:176) Loading: \SystemRoot\system32\drivers\kbdclass.sys at F7700000 with 14 pages
(ntoskrnl/mm/ARM3/sysldr.c:176) Loading: \SystemRoot\system32\drivers\mouclass.sys at F76F2000 with e pages
(ntoskrnl/mm/ARM3/sysldr.c:176) Loading: \SystemRoot\system32\drivers\floppy.sys at F76D9000 with 19 pages
(ntoskrnl/io/iomgr/driver.c:1585) '\Driver\FLOPPY' initialization failed, status (0xc000000e)
(ntoskrnl/io/iomgr/driver.c:64) Deleting driver object '\Driver\FLOPPY'
(ntoskrnl/io/iomgr/driver.c:1995) IopInitializeDriverModule() failed (Status c000000e)
(ntoskrnl/mm/ARM3/sysldr.c:955) Leaking driver: floppy.sys
(ntoskrnl/mm/ARM3/sysldr.c:176) Loading: \SystemRoot\system32\drivers\cdrom.sys at F76BA000 with 1b pages
(ntoskrnl/mm/ARM3/sysldr.c:176) Loading: \SystemRoot\system32\drivers\fs_rec.sys at F76AC000 with e pages
(ntoskrnl/mm/ARM3/sysldr.c:176) Loading: \SystemRoot\system32\drivers\null.sys at F76A3000 with 9 pages
(ntoskrnl/mm/ARM3/sysldr.c:176) Loading: \SystemRoot\system32\drivers\beep.sys at F769A000 with 9 pages
(ntoskrnl/mm/ARM3/sysldr.c:176) Loading: \SystemRoot\system32\drivers\blue.sys at F768F000 with b pages
(ntoskrnl/mm/ARM3/sysldr.c:176) Loading: \SystemRoot\system32\drivers\msfs.sys at F7684000 with b pages
(ntoskrnl/mm/ARM3/sysldr.c:176) Loading: \SystemRoot\system32\drivers\npfs.sys at F7662000 with 22 pages
(ntoskrnl/mm/ARM3/sysldr.c:176) Loading: \SystemRoot\system32\drivers\ndisuio.sys at F7653000 with f pages
(ntoskrnl/mm/ARM3/sysldr.c:176) Loading: \SystemRoot\system32\drivers\afd.sys at F7624000 with 2f pages
WARNING:  RtlCreateTagHeap at sdk/lib/rtl/heap.c:3881 is UNIMPLEMENTED!
(base/system/autochk/autochk.c:422) AUTOCHK: Checking \??\C:
(base/system/smss/pagefile.c:878) SMSS:PFILE: Open volume `\??\D:\' failed with status C000014F
Boot took 23355758517 cycles!
Interrupts: 1129 System Calls: 14590 Context Switches: 756
(ntoskrnl/config/cmsysini.c:1238) CmpGetRegistryPath: ConfigPath = '\SystemRoot\System32\Config\'
(ntoskrnl/config/cmsysini.c:1238) CmpGetRegistryPath: ConfigPath = '\SystemRoot\System32\Config\'
(ntoskrnl/config/cmsysini.c:1238) CmpGetRegistryPath: ConfigPath = '\SystemRoot\System32\Config\'
(ntoskrnl/config/cmsysini.c:1238) CmpGetRegistryPath: ConfigPath = '\SystemRoot\System32\Config\'
(ntoskrnl/config/cmsysini.c:1238) CmpGetRegistryPath: ConfigPath = '\SystemRoot\System32\Config\'
(ntoskrnl/config/cmsysini.c:1238) CmpGetRegistryPath: ConfigPath = '\SystemRoot\System32\Config\'
(ntoskrnl/config/cmsysini.c:1238) CmpGetRegistryPath: ConfigPath = '\SystemRoot\System32\Config\'
(ntoskrnl/config/cmcheck.c:25) CmCheckRegistry(0xB49B1008, 0) is UNIMPLEMENTED!
(ntoskrnl/config/cmcheck.c:25) CmCheckRegistry(0xB49B0008, 0) is UNIMPLEMENTED!
(ntoskrnl/config/cmcheck.c:25) CmCheckRegistry(0xB49AD008, 0) is UNIMPLEMENTED!
(ntoskrnl/config/cmcheck.c:25) CmCheckRegistry(0xB49AF3E8, 0) is UNIMPLEMENTED!
(ntoskrnl/mm/ARM3/session.c:790) Session 0 is ready to go: 0xBF7F0000 0xF75F8000, 7f6f5 0xB49B2288
(ntoskrnl/mm/ARM3/sysldr.c:176) Loading: \SystemRoot\System32\win32k.sys at F7327000 with 2b9 pages
(ntoskrnl/mm/ARM3/sysldr.c:176) Loading: \SystemRoot\System32\ftfd.dll at F71F4000 with 133 pages
(ntoskrnl/mm/ARM3/sysldr.c:176) Loading: \SystemRoot\System32\framebuf.dll at F71E7000 with d pages
(win32ss/user/ntuser/class.c:2335) err: SYSTEMCUR(ARROW) == NULL, should not happen!!
(win32ss/user/ntuser/class.c:2335) err: SYSTEMCUR(ARROW) == NULL, should not happen!!
(win32ss/user/ntuser/class.c:2335) err: SYSTEMCUR(ARROW) == NULL, should not happen!!
(win32ss/user/ntuser/class.c:2335) err: SYSTEMCUR(ARROW) == NULL, should not happen!!
(win32ss/user/ntuser/class.c:2335) err: SYSTEMCUR(ARROW) == NULL, should not happen!!
(win32ss/user/ntuser/class.c:2335) err: SYSTEMCUR(ARROW) == NULL, should not happen!!
(win32ss/user/ntuser/winsta.c:241) err: Invalid window station handle
(win32ss/user/ntuser/clipboard.c:31) err: Cannot open winsta
(win32ss/user/ntuser/winsta.c:493) err: Initializing input window station
(win32ss/user/ntuser/desktop.c:3240) err: The process 0xB472F478 'winlogon.exe' didn't have an assigned startup desktop before, assigning it now!
(win32ss/user/ntuser/desktop.c:3178) err: Attempted to change thread desktop although the thread has windows!
(win32ss/user/winsrv/usersrv/init.c:157) We are logged off
(ntoskrnl/mm/ARM3/sysldr.c:176) Loading: \SystemRoot\System32\kbdus.dll at F71C2000 with 5 pages
(dll/win32/userenv/profile.c:781) Error: 2
(dll/win32/userenv/profile.c:914) Error: 2
VBEMP: VBESetCurrentMode failed (14f)
(win32ss/gdi/eng/pdevobj.c:245) Failed to create PDEV surface!
VBEMP: VBESetCurrentMode failed (14f)
(win32ss/gdi/eng/pdevobj.c:245) Failed to create PDEV surface!
err:(win32ss/user/user32/windows/cursoricon.c:25) Loading System Cursors
VBEMP: VBESetCurrentMode failed (14f)
(win32ss/gdi/eng/pdevobj.c:245) Failed to create PDEV surface!
VBEMP: VBESetCurrentMode failed (14f)
(win32ss/gdi/eng/pdevobj.c:245) Failed to create PDEV surface!
VBEMP: VBESetCurrentMode failed (14f)
(win32ss/gdi/eng/pdevobj.c:245) Failed to create PDEV surface!
VBEMP: VBESetCurrentMode failed (14f)
(win32ss/gdi/eng/pdevobj.c:245) Failed to create PDEV surface!
VBEMP: VBESetCurrentMode failed (14f)
(win32ss/gdi/eng/pdevobj.c:245) Failed to create PDEV surface!
VBEMP: VBESetCurrentMode failed (14f)
(win32ss/gdi/eng/pdevobj.c:245) Failed to create PDEV surface!
VBEMP: VBESetCurrentMode failed (14f)
(win32ss/gdi/eng/pdevobj.c:245) Failed to create PDEV surface!
VBEMP: VBESetCurrentMode failed (14f)
(win32ss/gdi/eng/pdevobj.c:245) Failed to create PDEV surface!
VBEMP: VBESetCurrentMode failed (14f)
(base/system/services/services.c:63) ScmLogEvent: RegisterEventSourceW failed 1722
(dll/win32/userenv/profile.c:781) Error: 2
(dll/win32/userenv/profile.c:914) Error: 2
(win32ss/gdi/eng/pdevobj.c:245) Failed to create PDEV surface!
VBEMP: VBESetCurrentMode failed (14f)
(win32ss/gdi/eng/pdevobj.c:245) Failed to create PDEV surface!
VBEMP: VBESetCurrentMode failed (14f)
(win32ss/gdi/eng/pdevobj.c:245) Failed to create PDEV surface!
VBEMP: VBESetCurrentMode failed (14f)
(win32ss/gdi/eng/pdevobj.c:245) Failed to create PDEV surface!
VBEMP: VBESetCurrentMode failed (14f)
(win32ss/gdi/eng/pdevobj.c:245) Failed to create PDEV surface!
VBEMP: VBESetCurrentMode failed (14f)
(win32ss/gdi/eng/pdevobj.c:245) Failed to create PDEV surface!
VBEMP: VBESetCurrentMode failed (14f)
(win32ss/gdi/eng/pdevobj.c:245) Failed to create PDEV surface!
VBEMP: VBESetCurrentMode failed (14f)
(win32ss/gdi/eng/pdevobj.c:245) Failed to create PDEV surface!
VBEMP: VBESetCurrentMode failed (14f)
(win32ss/gdi/eng/pdevobj.c:245) Failed to create PDEV surface!
VBEMP: VBESetCurrentMode failed (14f)
(win32ss/gdi/eng/pdevobj.c:245) Failed to create PDEV surface!
VBEMP: VBESetCurrentMode failed (14f)
(win32ss/gdi/eng/pdevobj.c:245) Failed to create PDEV surface!
VBEMP: VBESetCurrentMode failed (14f)
(win32ss/gdi/eng/pdevobj.c:245) Failed to create PDEV surface!
VBEMP: VBESetCurrentMode failed (14f)
(win32ss/gdi/eng/pdevobj.c:245) Failed to create PDEV surface!
VBEMP: VBESetCurrentMode failed (14f)
(win32ss/gdi/eng/pdevobj.c:245) Failed to create PDEV surface!
VBEMP: VBESetCurrentMode failed (14f)
(win32ss/gdi/eng/pdevobj.c:245) Failed to create PDEV surface!
VBEMP: VBESetCurrentMode failed (14f)
(win32ss/gdi/eng/pdevobj.c:245) Failed to create PDEV surface!
VBEMP: VBESetCurrentMode failed (14f)
(win32ss/gdi/eng/pdevobj.c:245) Failed to create PDEV surface!
VBEMP: VBESetCurrentMode failed (14f)
(win32ss/gdi/eng/pdevobj.c:245) Failed to create PDEV surface!
VBEMP: VBESetCurrentMode failed (14f)
(win32ss/gdi/eng/pdevobj.c:245) Failed to create PDEV surface!
VBEMP: VBESetCurrentMode failed (14f)
(win32ss/gdi/eng/pdevobj.c:245) Failed to create PDEV surface!
VBEMP: VBESetCurrentMode failed (14f)
(win32ss/gdi/eng/pdevobj.c:245) Failed to create PDEV surface!
VBEMP: VBESetCurrentMode failed (14f)
(win32ss/gdi/eng/pdevobj.c:245) Failed to create PDEV surface!
err:(win32ss/user/user32/misc/dllmain.c:601) hIconSmWindows 00020064 hIconWindows 00020062 
(win32ss/user/ntuser/callback.c:1138) err: hIconSmWindows 00020064 hIconWindows 00020062 
VBEMP: VBESetCurrentMode failed (14f)
(win32ss/gdi/eng/pdevobj.c:245) Failed to create PDEV surface!
VBEMP: VBESetCurrentMode failed (14f)
(win32ss/gdi/eng/pdevobj.c:245) Failed to create PDEV surface!
VBEMP: VBESetCurrentMode failed (14f)
(win32ss/gdi/eng/pdevobj.c:245) Failed to create PDEV surface!
VBEMP: VBESetCurrentMode failed (14f)
(win32ss/gdi/eng/pdevobj.c:245) Failed to create PDEV surface!
VBEMP: VBESetCurrentMode failed (14f)
(win32ss/gdi/eng/pdevobj.c:245) Failed to create PDEV surface!
VBEMP: VBESetCurrentMode failed (14f)
(win32ss/gdi/eng/pdevobj.c:245) Failed to create PDEV surface!
(win32ss/user/ntuser/desktop.c:3178) err: Attempted to change thread desktop although the thread has windows!
VBEMP: VBESetCurrentMode failed (14f)
(win32ss/gdi/eng/pdevobj.c:245) Failed to create PDEV surface!

*** Assertion failed: ppdev->pSurface != NULL
***   Source File: /srv/buildbot/Build_GCCLin_x86/build/win32ss/gdi/eng/mouse.c, line 52

Break repeatedly, break Once, Ignore, terminate Process or terminate Thread (boipt)? 
kdb:> 

Walt
Posts: 20
Joined: Tue Sep 04, 2018 1:39 am

Re: ROS 4.10/4.11 hang on boot after 'Verifying the file system'

Post by Walt » Thu Sep 20, 2018 2:55 am

The corollary to "The hurrier I go the behinder I get" is "The more I study the less I know." After all of the above I watched the youtube video showing the install of ROS on a Dell D630 laptop. He did nothing unusual, but I do have a D610 so why not? I had loaded 0.4.11 onto a 2.5" PATA disk last night, found that it failed on the Dimension 3000 just like all the others, and set it aside: I swapped that disk into the 610 in place of a working XP system, got ready to boot the install CD, and before I could get it in the drive ROS came right up. EXACT same system that has uniformly failed on the 3000 -- also a working machine with XP.

Moreover, when doing the second stage on the D610 ROS complained of the pagefile.sys length error that the other machine had. It fixed it and went right on.

This is obviously 'alpha' code -- stuff doesn't work because it's not yet implemented -- but I'm a lot more impressed by what's there than what's not. Not often mentioned here is that there are many small tweaks to usability -- defaults that MS got wrong in XP that are corrected in ROS. VERY slick work and not that far from ready for regular use here. I need to get the Internet, then I guess wait for support for a late version of Firefox or ??? 3/4 of my computer use is 'net access, so when ROS has a good browser i'll run it regularly.

What does work has a polished feel to it. I expect other users know what I mean.

I sure would rather have it on the desktop machine, but the story is probably in the log posted above when someone has time to tackle it. I note a youtube of someone trying ROS on 7 different PC's: I'd like to know his batting average but I'm not 28 minutes interested.

Post Reply

Who is online

Users browsing this forum: No registered users and 2 guests