ReactOS 0.4.11 Problems with installation on real hardware

Ask your support questions in here

Moderator: Moderator Team

Post Reply
Tyco72
Posts: 5
Joined: Thu Feb 14, 2019 2:40 pm

ReactOS 0.4.11 Problems with installation on real hardware

Post by Tyco72 » Tue Mar 12, 2019 12:06 am

Hello everyone, this is my first test with ReactOS. This is my report:

On my newer PC, motherboard Gigabyte GA-990FXA-UD5 (Chipset AMD990FX + AMD SB950):
- React OS (normal installer, not debug version) can be installed, but ReactOS can't complete to start. Starting it with the "screen" mode option, I see it stops by the line 905. See attached screenshot.
- I have tried also the installer of the debug build 4.12, but it doesn't complete the installation,
- The live CD of the normal version works. The USB ports are recognized and looks to be installed, but if I plug in a USB stick, ReactOS freezes.

On my older PC, motherboard Gigabyte GA-K8N Ultra-9 (chipset Nvidia nForce4), video card: ATI Radeon 7500 - 64 MB:
-The installation stays in a black screen after to have shown the message "Loading boot drivers"
-The live CD stops by loading the file: SWENUM.SYS

Please tell me how I can provide logs, if someone needs.

Edit: I should have posted it in the first topic of this section. I thought it was a closed topic... On both PC

karlexceed
Posts: 454
Joined: Thu Jan 10, 2013 6:17 pm
Contact:

Re: ReactOS 0.4.11 Problems with installation on real hardware

Post by karlexceed » Tue Mar 12, 2019 3:45 pm

Tyco72 wrote:
Tue Mar 12, 2019 12:06 am
See attached screenshot.
?
Tyco72 wrote:
Tue Mar 12, 2019 12:06 am
if I plug in a USB stick, ReactOS freezes.
USB support is still troublesome; this is to be expected.
Tyco72 wrote:
Tue Mar 12, 2019 12:06 am
The live CD stops by loading the file: SWENUM.SYS
This is a common error - check out the other forum posts which mention this: https://www.reactos.org/forum/search.ph ... SWENUM.SYS
Tyco72 wrote:
Tue Mar 12, 2019 12:06 am
Please tell me how I can provide logs
https://reactos.org/wiki/Debugging Should get you started on what you need to know.

Tyco72
Posts: 5
Joined: Thu Feb 14, 2019 2:40 pm

Re: ReactOS 0.4.11 Problems with installation on real hardware

Post by Tyco72 » Tue Mar 12, 2019 9:37 pm

Now I could upload the images (but I don't see them in the preview here), and I have an update:

If I disconnect the USB mouse, ReactOS proceeds a little more with the startup, but it stops and freezes anyway:
https://postimg.cc/8F93fRk0
Image

The strange thing is that in the same PC, the live CD of ReactOS works, and the USB mouse works too. Probably the build of the installation CD contains something different.

The application to launch the installation from the live CD, doesn't work.

This is the startup of the installed ReactOS when the USB mouse connected:
https://postimg.cc/4Kmq3LGc
Image

In both cases, the screen and the keyboard freeze, so I can't enter the command "bt" to generate a debug (as indicated in the first thread of this section)
I hope this can be useful. To take debugs through the serial port is not possible in my system.

Reactions
Posts: 211
Joined: Mon Dec 31, 2018 3:30 am

Re: ReactOS 0.4.11 Problems with installation on real hardware

Post by Reactions » Wed Mar 13, 2019 10:49 pm

Here is how to fix USB issues.

viewtopic.php?f=4&t=13266
Please support/share my Patreon! Helps so much! https://www.patreon.com/reactions

Tyco72
Posts: 5
Joined: Thu Feb 14, 2019 2:40 pm

Re: ReactOS 0.4.11 Problems with installation on real hardware

Post by Tyco72 » Sat Mar 16, 2019 12:23 pm

I have took al look. There are some workarounds to try, but I don't understand why the live CD works with the same hardware. Therefore it should be not because of the USB, unless the boot CD contains different USB drivers than the live CD.
If they contains the same drivers, it would guess that it is a problem with the SATA/HDD drivers.

binarymaster
Posts: 265
Joined: Sun Nov 16, 2014 7:05 pm
Location: Russia, Moscow
Contact:

Re: ReactOS 0.4.11 Problems with installation on real hardware

Post by binarymaster » Sun Mar 17, 2019 1:31 pm

Tyco72 wrote:
Sat Mar 16, 2019 12:23 pm
but I don't understand why the live CD works with the same hardware.
Live CD and Boot CD uses different HAL drivers.

davidinark
Posts: 1
Joined: Tue Mar 26, 2019 12:47 am

Re: ReactOS 0.4.11 Problems with installation on real hardware

Post by davidinark » Tue Mar 26, 2019 1:01 am

Did you (OP) ever get it to work?

I looked through the linked thread and it points to VERY old versions which supposedly had the USB HAL injected. Yet, the newer builds do not? As an aside, why would devs not include the same HAL in the release as the live CD?

FWIW, My CD boots, but as soon as the language option is offered, the KB light goes out and I can't do anything. And, yes, I know we are trying to install it on real HW, which presents its own problems, but still...

Post Reply

Who is online

Users browsing this forum: No registered users and 2 guests