Page 1 of 1

New install under Oracle VM VirtualBox crashes during boot

Posted: Sat May 25, 2019 10:00 pm
by CyberGonzo
First time user.
Downloaded latest and greatest BootCD v 0.4.11 ( https://reactos.org/download )
Created a new 'machine' using Oracle VM VirtualBox Version 5.2.30 r130521 (Qt5.6.2)
and followed 'Running the ReactOS Live CD' detailed here: https://reactos.org/wiki/VirtualBox to the letter.
Disconnected the installation CD started the VM.

Every single time, no matter what type OS (Debug, ....) I choose, boot simply stops and VirtualBox displays 'aborted'.

Not sure what to do to debug.
Kindly let me know what type information you need to debug (and fix?) this issue.

Re: New install under Oracle VM VirtualBox crashes during boot

Posted: Tue May 28, 2019 3:16 pm
by karlexceed
Are you able to make it through the second stage installer where you can choose a username, computer name, time zone, etc?

Re: New install under Oracle VM VirtualBox crashes during boot

Posted: Tue May 28, 2019 4:34 pm
by binarymaster
karlexceed wrote:
Tue May 28, 2019 3:16 pm
Are you able to make it through the second stage installer where you can choose a username, computer name, time zone, etc?
Second stage? :| According to the OP post, his VBox VM crashes early when loading the kernel.
CyberGonzo wrote:
Sat May 25, 2019 10:00 pm
Every single time, no matter what type OS (Debug, ....) I choose, boot simply stops and VirtualBox displays 'aborted'.
This could be some VBox bug or misconfiguration of the VM.

Re: New install under Oracle VM VirtualBox crashes during boot

Posted: Tue May 28, 2019 4:44 pm
by CyberGonzo
No second stage no.
Boot simply aborts before any user input is requested.

Re: New install under Oracle VM VirtualBox crashes during boot

Posted: Tue May 28, 2019 6:02 pm
by karlexceed
binarymaster wrote:
Tue May 28, 2019 4:34 pm
Second stage? :| According to the OP post, his VBox VM crashes early when loading the kernel.
CyberGonzo wrote:
Sat May 25, 2019 10:00 pm
...latest and greatest BootCD v 0.4.11...

Every single time, no matter what type OS (Debug, ....) I choose, boot simply stops and VirtualBox displays 'aborted'.
To get to the screen where you can choose a Debug option with a Boot CD, you should have made it through the first stage installer (text-based, lots of blue, very old school). Otherwise, you are using a Live CD.

Unfortunately, I've tested both today with my VBox 6.0.8 r130520 running on Windows 7 64-bit and it "Works for Me™".

What's your host OS?

Re: New install under Oracle VM VirtualBox crashes during boot

Posted: Tue May 28, 2019 6:15 pm
by CyberGonzo
No I made sure to download the boot CD.
During first install I did go through the old style (lots of blue) options. Language selection, formatting etc.
After all that the OS wants to boot, but that never succeeds.

I am on a Windows 10 Acer (Aspire V17 Nitro) laptop, a couple years old.
I upgraded to the latest and greatest VBox as suggested by VBox itself but didn't realize there is also a 6.x version.
Do you suspect it could be VBox ? If so I should be able to upgrade to VBox v. 6.x and test things without corrupting all my other existing VMs.

Re: New install under Oracle VM VirtualBox crashes during boot

Posted: Tue May 28, 2019 10:46 pm
by karlexceed
The fact that it 'aborts' rather than giving an error inside the VM like a BSOD or something else does suggest to me some issue with the virtualization. I know there were some issues with VBox 5.x, but I'm not sure if it was ever something like this specifically.

You could review your VBox logs or try to use the virtual serial port to capture debug info ( https://reactos.org/wiki/VirtualBox#Windows ). This could help to figure out what's happening.

But I'd recommend to upgrade your VBox installation and try again. It shouldn't affect any other VMs, but I can't make any guarantees there.

Re: New install under Oracle VM VirtualBox crashes during boot

Posted: Tue May 28, 2019 11:44 pm
by CyberGonzo
VBox keeps a few logs, so not sure which one is relevant.
But the two last lines of VBoxHardening may be useful:

3668.3124: supR3HardNtChildWaitFor[2]: Quitting: ExitCode=0xc0000374 (rcNtWait=0x0, rcNt1=0x0, rcNt2=0x103, rcNt3=0x103, 12531 ms, the end);
de0.1778: supR3HardNtChildWaitFor[1]: Quitting: ExitCode=0xc0000374 (rcNtWait=0x0, rcNt1=0x0, rcNt2=0x103, rcNt3=0x103, 13577 ms, the end);

When I look up the exit code 0xc0000374 it seems to point to heap corruption
(also fyi: https://forums.virtualbox.org/viewtopic.php?f=6&t=80994 )

That's annoying. All my other VMs work OK btw.
It must be a bug in VBox in combination with ReactOS on my system.

Re: New install under Oracle VM VirtualBox crashes during boot

Posted: Wed May 29, 2019 4:27 pm
by CyberGonzo
OK, so I started fresh, created a new VM under VBox 6.x and I kept all the default setting, both in the VM setup (nothing changed) and during the initial install (old style blue).
This time I could proceed (second step?) and could enter selections in a GUI. Whoohoo.
After a required reboot booting now simply hangs until also aborted, so I 'whoohood' too fast :)

Initially, under VBox 5.x I had increased memory for the VM and made a few other selections as well (UK English vs US English etc).
I now reverted memory to the default for this VM and made sure all settings are the same as the VM created under 6.x but to no avail.
Booting still fails.

I wanted to test my software on this OS to see if it worked but I think it's too soon. Things need to mature a bit more. Perhaps I'll come back to this in the future.

Re: New install under Oracle VM VirtualBox crashes during boot

Posted: Wed May 29, 2019 7:12 pm
by karlexceed
I'm sorry you're having such a rough time getting ReactOS to run. I install/re-install ROS dozens of times a week and almost never run into issues.

For the record, I use VBox with the Windows 2003 32 bit template. Accept all defaults. Then increase RAM to 2048 MB, set mouse to PS2, and use PCnet-FAST III network card set as bridged. Install using a Boot CD, accept all defaults except to change my time zone in second stage. Rarely do I install Gecko.

It usually takes less than 5 minutes to get to a running desktop, and I've done this with VBox on top of Windows 7, Windows 10, and Ubuntu. I've even run ROS on top of VMware ESX and v86 in my browser!

Re: New install under Oracle VM VirtualBox crashes during boot

Posted: Wed May 29, 2019 8:20 pm
by CyberGonzo
I tried again, the only difference I believe is that I did not set 'bridged' to the network adaptor before.
This time it worked ! Finally :) Thank you.

I tested. My software doesn't function properly on the OS. Debug tools also appear to fail.
I'm glad installation finally worked but I'll have to come back to this in the future.