Reactos Build Error, please help.

Ask your support questions in here

Moderator: Moderator Team

Post Reply
Lucio Diaz
Posts: 107
Joined: Fri Nov 26, 2004 10:12 pm
Location: España (perdido en el atlantico)

Reactos Build Error, please help.

Post by Lucio Diaz » Wed Mar 30, 2005 2:29 am

I am building in windows XP

Using the build suite at http://reactos.com/wiki/index.php/Build_Environment

I have the path set

I have make clean a few times

I have updated my source tree with "svn up"

I have checked that cc1 reports version 3.4.2 and is availabe in the path

I have checked that as.exe reports version 2.15.94

But there is NO WAY, am keeps having this error since i went back to build reactos sience more than a month not doing so, but with all the building environment fully updated:

Code: Select all

rosrtl: [DEPENDS] file/.path.d
rosrtl: [DEPENDS] file/.sparse.d
rosrtl: [DEPENDS] registry/.registry.d
rosrtl: [DEPENDS] string/.resstr.d
rosrtl: [DEPENDS] string/.append.d
rosrtl: [DEPENDS] misc/.logfont.d
rosrtl: [DEPENDS] misc/.intrlck.d
rosrtl: [DEPENDS] misc/.devmode.d
rosrtl: [DEPENDS] thread/i386/.context.d
rosrtl: [DEPENDS] thread/.linearstack.d
rosrtl: [DEPENDS] thread/.priv.d
rosrtl: [DEPENDS] thread/.stack.d
rosrtl: [DEPENDS] thread/.exit.d
rosrtl: [DEPENDS] thread/.create.d
rosrtl: [DEPENDS] recmutex/.recmutex.d
gcc: installation problem, cannot exec `C:\MingW\bin\..\libexec\gcc\mingw32\3.4.
2\cc1.exe': Invalid argument
rosrtl: [DEPENDS] file/.path.d
gcc: installation problem, cannot exec `C:\MingW\bin\..\libexec\gcc\mingw32\3.4.
2\cc1.exe': Invalid argument
rosrtl: [DEPENDS] file/.sparse.d
gcc: installation problem, cannot exec `C:\MingW\bin\..\libexec\gcc\mingw32\3.4.
2\cc1.exe': Invalid argument
rosrtl: [DEPENDS] registry/.registry.d
gcc: installation problem, cannot exec `C:\MingW\bin\..\libexec\gcc\mingw32\3.4.
2\cc1.exe': Invalid argument
rosrtl: [DEPENDS] string/.resstr.d
gcc: installation problem, cannot exec `C:\MingW\bin\..\libexec\gcc\mingw32\3.4.
2\cc1.exe': Invalid argument
rosrtl: [DEPENDS] string/.append.d
gcc: installation problem, cannot exec `C:\MingW\bin\..\libexec\gcc\mingw32\3.4.
2\cc1.exe': Invalid argument
rosrtl: [DEPENDS] misc/.logfont.d
gcc: installation problem, cannot exec `C:\MingW\bin\..\libexec\gcc\mingw32\3.4.
2\cc1.exe': Invalid argument
rosrtl: [DEPENDS] misc/.intrlck.d
gcc: installation problem, cannot exec `C:\MingW\bin\..\libexec\gcc\mingw32\3.4.
2\cc1.exe': Invalid argument
rosrtl: [DEPENDS] misc/.devmode.d
gcc: installation problem, cannot exec `C:\MingW\bin\..\libexec\gcc\mingw32\3.4.
2\cc1.exe': Invalid argument
rosrtl: [DEPENDS] thread/i386/.context.d
gcc: installation problem, cannot exec `C:\MingW\bin\..\libexec\gcc\mingw32\3.4.
2\cc1.exe': Invalid argument
rosrtl: [DEPENDS] thread/.linearstack.d
gcc: installation problem, cannot exec `C:\MingW\bin\..\libexec\gcc\mingw32\3.4.
2\cc1.exe': Invalid argument
rosrtl: [DEPENDS] thread/.priv.d
gcc: installation problem, cannot exec `C:\MingW\bin\..\libexec\gcc\mingw32\3.4.
2\cc1.exe': Invalid argument
rosrtl: [DEPENDS] thread/.stack.d
gcc: installation problem, cannot exec `C:\MingW\bin\..\libexec\gcc\mingw32\3.4.
2\cc1.exe': Invalid argument
rosrtl: [DEPENDS] thread/.exit.d
gcc: installation problem, cannot exec `C:\MingW\bin\..\libexec\gcc\mingw32\3.4.
2\cc1.exe': Invalid argument
rosrtl: [DEPENDS] thread/.create.d
gcc: installation problem, cannot exec `C:\MingW\bin\..\libexec\gcc\mingw32\3.4.
2\cc1.exe': Invalid argument
rosrtl: [CC]      thread/create.c
gcc: installation problem, cannot exec `C:\MingW\bin\..\lib\gcc\mingw32\3.4.2\..
\..\..\..\mingw32\bin\as.exe': Invalid argument
mingw32-make[1]: *** [thread/create.o] Error 1
mingw32-make: *** [rosrtl] Error 2

C:\Internet\ReactOS\Subersion\reactos>ECHO Press Enter to make install now . . .

Press Enter to make install now . . .

C:\Internet\ReactOS\Subersion\reactos>SET /P =
What can i do?

GvG
Posts: 499
Joined: Mon Nov 22, 2004 10:50 pm
Location: The Netherlands

Post by GvG » Wed Mar 30, 2005 10:17 am

gcc: installation problem, cannot exec C:\MingW\bin\..\libexec\gcc\mingw32\3.4.2\cc1.exe': Invalid argument
It seems to be an installation problem.... Have you checked that the file it complains about actually exists (that would be C:\MingW\libexec\gcc\mingw32\3.4.2\cc1.exe if you remove the ".." from the path).

Lucio Diaz
Posts: 107
Joined: Fri Nov 26, 2004 10:12 pm
Location: España (perdido en el atlantico)

Post by Lucio Diaz » Thu Mar 31, 2005 11:05 pm

Yes it exists this is the path:

C:\MingW\libexec\gcc\mingw32\3.4.2

So i can not imagine what is wrong.

mjs
Posts: 47
Joined: Sat Feb 19, 2005 9:03 pm

Post by mjs » Sat Apr 02, 2005 2:57 am

Can you successfully compile a "hello world" sample?

When you cannot, think about re-installing MinGW.

Regards,
Mark

Post Reply

Who is online

Users browsing this forum: Baidu [Spider] and 2 guests