Installing Nvidia drivers

Ask your support questions in here

Moderator: Moderator Team

Zombiedeth
Posts: 107
Joined: Fri Jun 27, 2014 9:01 am

Installing Nvidia drivers

Post by Zombiedeth » Mon Feb 22, 2016 1:56 pm

So with the new release of ReactOS i figured it was a good time to test video drivers again. it seems things have progressed a bit farther.
I'm testing a GeForce 6600 using the following drivers:

http://us.download.nvidia.com/Windows/9 ... h_whql.exe

When installing the drivers i do run into a snag it keeps displaying a dialog box about NVDISP.NVU during the copy process but doesn't matter how many times i hit it keeps coming back. and drivers are not installed

Image

if i rename this file so it can't be found the process does complete

Image

I get this error dialog about 3 times before it's done i have tested this in Windows XP with the same drivers and the drivers install and seem to work properly when renaming NVDISP.NVU. so i think this is a valid workaround.

Image

Image

All seems ok till i reboot ReactOS hangs after the driver is loaded if i select screen at boot i get the following:

Image

oldman
Posts: 1009
Joined: Sun Dec 20, 2009 1:23 pm

Re: Installing Nvidia drivers

Post by oldman » Mon Feb 22, 2016 3:41 pm

I have had the same thing (ERROR_SUCCESS) with GForce3 drivers, when I have tried to install the network driver. The way I got around it was, to go to the Task Manager and kill the process, but not the setup.exe, then the ReactOS hardware wizard opened and I installed the driver that way.
Please keep the Windows classic (9x/2000) look and feel.
The layman's guides to - debugging - bug reporting - compiling - with some complementary scripts.
They may help you with a problem, so do have a look at them.

sdever
Posts: 18
Joined: Fri Oct 16, 2015 6:45 pm

Re: Installing Nvidia drivers

Post by sdever » Mon Feb 22, 2016 4:04 pm

Hello,

Please create a new bugreport in JIRA, since it's easier for developers to keep track of them.

Btw looking at the code, it seems that the current implementation of VideoPortGetProcAddress is quite broken and should rely on export table parsing I guess (instead of manually track exported functions)

Zombiedeth
Posts: 107
Joined: Fri Jun 27, 2014 9:01 am

Re: Installing Nvidia drivers

Post by Zombiedeth » Mon Feb 22, 2016 5:56 pm

I wish i could file a JIRA report but my login does not work there.

gonzoMD
Posts: 993
Joined: Fri Oct 20, 2006 7:49 am
Location: Germany
Contact:

Re: Installing Nvidia drivers

Post by gonzoMD » Mon Feb 22, 2016 6:52 pm

Zombiedeth wrote:I wish i could file a JIRA report but my login does not work there.
It needs up to 24 hrs after registration to sync the database

Zombiedeth
Posts: 107
Joined: Fri Jun 27, 2014 9:01 am

Re: Installing Nvidia drivers

Post by Zombiedeth » Mon Feb 22, 2016 7:15 pm

My account was created in 2014 so it should have synced by now but guess not. :?
Is there a admin i can contact to fix my login?

hbelusca
Developer
Posts: 1034
Joined: Sat Dec 26, 2009 10:36 pm
Location: Zagreb, Croatia

Re: Installing Nvidia drivers

Post by hbelusca » Mon Feb 22, 2016 9:29 pm

@ Zombiedeth: can you please retest with this build of videoprt.sys: http://rghost.net/7YKnXHHXS which comes from ReactOS build r70770 ? (The link is valid for 30 days).

Zombiedeth
Posts: 107
Joined: Fri Jun 27, 2014 9:01 am

Re: Installing Nvidia drivers

Post by Zombiedeth » Mon Feb 22, 2016 10:45 pm

That cleared up some of the errors.

Image

hbelusca
Developer
Posts: 1034
Joined: Sat Dec 26, 2009 10:36 pm
Location: Zagreb, Croatia

Re: Installing Nvidia drivers

Post by hbelusca » Mon Feb 22, 2016 10:59 pm

Ok thanks! I've looked at our code in the meantime, and the assertion FALSE that you encounters is due to (one of the numerous unimplemented) memory mapping methods.

hbelusca
Developer
Posts: 1034
Joined: Sat Dec 26, 2009 10:36 pm
Location: Zagreb, Croatia

Re: Installing Nvidia drivers

Post by hbelusca » Mon Feb 22, 2016 11:26 pm

Zombiedeth, here http://rghost.net/6BTgbVwGQ is a local build of ntoskrnl.exe (to be placed in system32) with an experimental patch for the assertion. Could you have a look at it please?

Zombiedeth
Posts: 107
Joined: Fri Jun 27, 2014 9:01 am

Re: Installing Nvidia drivers

Post by Zombiedeth » Mon Feb 22, 2016 11:48 pm

Sure happy to btw i tried the videoprt.sys from windows xp don't know if it may give some useful info.

Image

Zombiedeth
Posts: 107
Joined: Fri Jun 27, 2014 9:01 am

Re: Installing Nvidia drivers

Post by Zombiedeth » Tue Feb 23, 2016 12:47 am

Wow your good :D

Image

Image

hbelusca
Developer
Posts: 1034
Joined: Sat Dec 26, 2009 10:36 pm
Location: Zagreb, Croatia

Re: Installing Nvidia drivers

Post by hbelusca » Tue Feb 23, 2016 12:55 am

Zombiedeth, thank you for your testing :) The ntoskrnl patch was committed in revision 70774 by Pierre Schweitzer (I think it's worth mentioning in the Epic Win! thread).

Zombiedeth
Posts: 107
Joined: Fri Jun 27, 2014 9:01 am

Re: Installing Nvidia drivers

Post by Zombiedeth » Tue Feb 23, 2016 1:24 am

Glad i could help ReactOS is an amazing project.

Vort
Posts: 12
Joined: Wed Nov 09, 2011 7:37 pm
Location: Ukraine

Re: Installing Nvidia drivers

Post by Vort » Tue Feb 23, 2016 8:29 am

CORE-10065 is updated with 93.71 driver testing report.
Maybe you will be interested in this.

Post Reply

Who is online

Users browsing this forum: DotBot [Crawler] and 2 guests