Additional software tests

Here you can discuss ReactOS related topics.

Moderator: Moderator Team

matthiasbasler
Posts: 35
Joined: Sun Sep 18, 2016 9:53 am

Additional software tests

Post by matthiasbasler » Sun Sep 18, 2016 3:08 pm

This thread, last updated for ROS 0.4.9 RC32, shows the results of my own tests of ReactOS, including comments.
Environment for 0.4.2 test:
  • Boot CD tested on VirtualBox 5.1.4 on Win7(64Bit) host.
  • VM configuration: OS type: WinXP32, 3072MB RAM, 2 cores, VT-x + Nested Paging, AC97 + Network
  • VM graphics options: 3D support + 2D hardware support enabled
Environment for 0.4.5 test:
  • Boot CD tested on VirtualBox 5.1.22 on Win7(64Bit) host.
  • VM configuration: OS type: Win2003, 2048MB RAM, 1 core, I/O-APIC off, VT-x + Nested Paging, AC97 + Network
  • VM graphics options: tried both 3D support + 2D hardware support enabled resp. disabled (See note for VLC below)
Environment for 0.4.6 - 0.4.9 test
  • Boot CD tested on VirtualBox 5.1.22 on Win7(64Bit) host (0.4.8+: Win10, 64Bit).
  • VM configuration: OS type: Win2003, 4096MB RAM, 32MB graphics memory, 1 core, I/O-APIC off, VT-x + Nested Paging, AC97 + Network
  • VM graphics options: 3D support + 2D hardware support enabled
Operating system/explorer UI issues found
  • 0.4.2 Solved in 0.4.7 Explorer and desktop don't update if files resp. shortcuts were added/removed. (Somewhat better from 0.4.5 on)
  • 0.4.2-0.4.6 Solved in 0.4.7 Cut/paste of files usually doesn't work, (Copy/paste usually works). Possibly related: CORE-10871)
  • 0.4.2-0.4.7 Solved in 0.4.8 Deleting folders does not work reliably or often only works after first deleting files within and doing a re-start. (CORE-12843)
  • 0.4.5-0.4.6 Solved in 0.4.7 Copying/moving both files and folders at the same time (e.g. using DnD) does not work. (CORE-12674)
  • 0.4.5-0.4.9 Starting/using files directly from a VBox shared folder results in error. Files have to be copied on local drive first. (CORE-10038)
  • 0.4.2-0.4.7 Applications make OS freeze easily. (Task manager doesn't respond any more, so can't kill processes, only restart helps.)
  • 0.4.8-0.4.9 Explorer doesn't show files pasted into or dragged to "My documents". Only F5 makes them visible. (Works in other folders.)
  • 0.4.8-0.4.9 Renaming files in explorer is sometimes not possible (Ctrl or Shift key permanently "on" CORE-14707).
Hardware/Drivers
Network (PCnet-FastIII)
  • 0.4.2-0.4.9: Works after installation
AC97 Sound (via Application manager)
  • 0.4.2: Works after driver installation and restarts. Hint: On first start (when drivers are detected), install driver via application manager and afterwards continue with the driver detection dialog. This way the driver is already there when needed. Notes: 1.) Driver needs at 2-3 restarts before working. 2.) For unknown reasons sound was later not working any more in a VM where it initially worked.
  • 0.4.5 Same as 0.4.2: Sound works, but as soon as the AC97 driver is applied, if a VirtualBox snapshot is created from running system, then starting the VM from this snapshot will result in a blue screen (BSOD) in ROS complaing about a STOP in "VBoxMouse.sys", Address F62231FD. Only Restart of the VM helps.
  • 0.4.6-0.4.9: Sound works after two restarts. Note: On my new Win10 host sound is now garbled whereas on my old one it is perfect.
VirtualBox graphics driver
  • 0.4.2: Works after installation from VB additions. Hint: First start ReactOS in safe mode, then mount VB additions and install driver. This way the experimental 3D component can be installed as well. (If the driver is installed in normal mode adding the 3D driver in safe mode later fails.) Notes: 1) 3D didn't work for me afterwards, although driver installed seemingly OK.
  • 0.4.5: Same as 0.4.2. Note that VLC player only plays videos if 2D/3D hardware acceleration is disabled/not installed.
  • 0.4.6-0.4.9: Works. 3D driver from guest additions must be installed in ReactOS safe mode.
Tahoma font
  • 0.4.2-0.4.9: Works. Hint: This font seems basically necessary to circumvent issues with the default font which cannot display ligatures correctly.
Libraries and runtimes
.net 2.0
  • 0.4.2-0.4.9: Works (and seems to help for applications requiring it).
.net 2.0 SP2
  • 0.4.9: Inst. works, no dependent applications tested.
.net 4.0
  • 0.4.5: Resulted in BSOD during restart after installation.
  • 0.4.6-0.4.9: Inst. works, no dependent applications tested.
Visual C++ / VB 6 Runtimes (via Application manager)
  • 0.4.5-0.4.9: Outer container deflates, but setup does not start and 7z detects a wrong checksum when extracting its files. (CORE-7646)
    Contained DLL files can however be manually copied to system32 folder, which might get some application working. More comfortably, right-click on the contained .inf file and choose "Install" in the context menu. This also copies the files.
Visual C++-Runtimes 2005-2013 (via Application manager)
  • 0.4.2-0.4.9: Inst. works, no applications using it tested yet. Note however, that at least on 0.4.6-0.4.8 installation of the the C++ 2012 and 2013 runtimes fails to start if .net 2.0 and SP2 have been installed previously. (CORE-14085). They can, however installed fine before .net 2.0. On ROS 0.4.8 the installer for VC++ 2008 shows flickering and "Finish" button becomes visible only after moving window.
Java 7u80 (via Application manager)
  • 0.4.2-0.4.5: Inst. works, no applications using it tested yet
  • 0.4.6: Inst. works, but java is not added to search path and "java -version" in installation folder prints nothing. It seems Java is not working. Test in browser fails too.
  • 0.4.7-0.4.9: Inst. works, Browser test is OK (albeit outdated version warning). Calling "java -version", even in jre7\bin folder, prints nothing.
Utilties/Internet
7zip 15.14 (via Application manager)
  • 0.4.2-0.4.7: Works
7zip 16.04 (via Application manager)
  • 0.4.8-0.4.9: Works
Notepad++ (via Application manager)
  • 0.4.5-0.4.8: Works. However during two installation runs, both updating the plugin manger and installing the "compare" plugin initially failed and did only work on second (or third) attempt.
  • 0.4.9: Works. However updater (gup.exe) shows error: "The procedure entry point GetTickCount64 could not be located in the dynamic link library kernel32.dll.".
Firefox 45ff.
  • 0.4.2: FF48.0.2 Offline inst. works, including Addons (Adblock Plus, Classic Theme Restorer). Notes: 1.)Slight UI update issues and some web pages show weird layouts compared to Win. 2.) Update of a Firefox installed via application manager failed.
  • 0.4.5: Inst. of FF45 from application manager works, auto-update to v47 also successful, further auto-updates failed (Win2003 no longer supported for newer versions of Firefox.)
  • 0.4.6-0.4.9: Manual inst. of FF48 works, including Addons (Adblock Plus, Classic Theme Restorer). Youtube shows HTML5 videos, albeit without sound. It seems any version later than FF48 does not work up to 0.4.9.
Adobe Flash offline installation
  • 0.4.2: v23.0 installation works. Notes: Livestreams still don't work, neither does youtube.
  • 0.4.6-0.4.8: Flash26/27 installation works. German ARD livesteam works afterwards. (Youtube already worked before.)
Adobe Flash online installation
  • 0.4.7-0.4.8 Fails. It worked in ROS 0.4.6 (usually after 2nd download attempt), but fails to start on ROS 0.4.7+ (CORE-13952)
  • 0.4.6, 0.4.9 Works thanks to revert of guilty commit (May take two attempts to download sometimes.)
Office
FoxitReader 7.x (via Application manager)
  • 0.4.2: v7.2.5 Works with reservations: Installation showed user.dll error but finished. Clicking on "File" menu brings up two error messages before continuing.
  • 0.4.5-0.4.9: v7.3.5 resp. v7.3.6: Installation was cancelled by setup program due to a detected error with printer configuration.
FoxitReader 8.2.1 (download from Heise Online)
  • 0.4.6-0.4.8: Manual inst. works, Application works for viewing PDF, except for the "Start" tab showing error dialogs with unsupported characters (only squares to be seen). Sometimes the application makes ROS crash with display artifacts.
  • 0.4.9: Manual inst. works, Application works for viewing PDF, except for the "Start" tab showing error dialogs with unsupported characters (only squares to be seen). Sometimes the application makes ROS crash with display artifacts or becomes unresponsive. File corruptions can happen, which results in attempts to repair them during next ROS boot.
Adobe Reader 5.0.5 (from 2001)
  • 0.4.2: Inst. OK, Works, Some settings pages crash application instantly (it just disappears).
Adobe Reader 7.0.7 (from 2006)
  • 0.4.2: Inst. OK, Works like a charm.
  • 0.4.7-0.4.8: Inst. complains for missing MSVCR71.dll (C++ 2003 runtime), but continues to install and works well.
Adobe Reader 9.3.0 (from 2010)
  • 0.4.2, 0.4.7-0.4.8: Inst. OK, Works, Setting pages pretty much unusable (e.g. text only appears when hovering with the mouse over it)
Adobe Reader XI Online installer from Adobe web page
  • 0.4.2-0.4.6: 11.0.10 Fails to install. Reports a newer version is already installed (which is a lie).
  • 0.4.7-0.4.8: 11.0.10 (for Win2003) Fails to download content, 11.0.08 (for WinXP) fails to initialize
  • 0.4.9: 11.0.10 Starts to download, but fails to install. Reports a newer version is already installed (which is a lie).
Adobe Reader XI Offline installer
  • 0.4.2-0.4.9: 11.0.08+11.0.10 fail to install. Reports the installation has been cancelled.
LibreOffice 5.x
  • 0.4.2/0.4.5: v5.2.1: Installation works, but fails to start (takes forever)
  • 0.4.6-0.4.9: v5.2.6 and v5.4.1: Installation works, application start very slow (1 minute). UI shows no cursor and reacts extremely slow, which makes editing a pain. General functions (load/save etc) work.
Graphics
FSImage Viewer Freeware (http://www.faststone.org/)
  • 0.4.2: v5.9 Works, only minor glitches in UI
  • 0.4.5-0.4.9: v6.1 resp. 6.4: Works, only minor glitches in UI (frames in thumbnail view)
Ulead PhotoImpact 10 SE (from CD, Commercial)
  • 0.4.2-0.4.9: Inst. works. Requires msvcirt.dll (from VC++6) in system32 in order to start. File dialog sees no images and DnD of image into program does't work either. By entering "*.jpg" as file name and pressing Enter, files appear. They can be loaded by double click even though "Open" button may remain greyed out. Most tested drawing/image manipulation functions work. Furthermore exiting the application does either not end process or makes ROS hang. (ROS0.4.9: Open button works in image load dialog.)
Ulead PhotoImpact 12 (Commercial)
  • 0.4.2-0.4.9: Installation works, but program fails to start. (Separate photo album application works.)
    The error on 0.4.7 reads "The instruction at "0x007dd943" referenced memory at "0x0000001c". The memory could not be "read". This is followed by a display error and a frozen ROS. Compatibiity mode (set to WinXP SP3) does not help.
RawTherapee (OpenSource)
  • 0.4.5-0.4.9: v5.0r1 (for "WinXP or newer") - Installation works, application starts and shows welcome screen, but hangs there with 100%CPU. Can be killed with task manager. No welcome screen but same problem on next start -> unusable (CORE-14086)
GBDeflickerApp (commercial)
  • 0.4.2/0.4.6-0.4.8: Inst. works, but activating a licence or demo licence fails technically: Lots of cmd dialogs pop up and close again, and in the end the application doesn't start.
  • 0.4.9: Inst. works, but trying to start the application does absolutely nothing.
PanoramaFactory 4.5 m32 (Commercial)
  • 0.4.2-0.4.7: Installation works, but startup with error message "You have selected a language that identifies an unknown locale" if German was chosen as installation language. Startup finally fails with Application error, ('The instruction at "0xx41c6d6 reference memory at "0x00000020". ...')
  • 0.4.8-0.4.9: Installation is said to start, but then installer disappears and never tells it is finished. Software is installed, however. Same error message during startup as above -> not working.
PanoramaFactory 4.5 (Win95 legacy edition) (Commercial)
  • 0.4.2-0.4.9: Installation works, but startup with error messages "You have selected a language that identifies an unknown locale" if German was chosen as installation language. Massive UI font issues in German version, "Reset to English" menu entry fixes them. -> CORE-13757 for the locale issues.
    Startup succeeds, application is somewhat usable, but fails at important steps like setting control points and stitching. (Runs at 100% CPU forever.) CORE-13765 -> Unusable.
Multimedia
Winamp 2.91
  • 0.4.2-0.4.8: Works, albeit with some UI re-drawing issues.
  • 0.4.9: Works well, no UI issues found. UI buttons are english (but menu is German)
VLC media player
  • 0.4.2: v2.2.2 (via application manager) or v2.2.4 (manual inst.) works incl. audio, but with limitations:
    1.) Some preferences pages make program crash. Hint: Use "All settings" option! 2.) Video output module must be set to "Windows GDI" (if Direct3D/DirectDraw is not working). 3.) Some videos showed image and audio out of sync (On Windows OK)
  • 0.4.5-0.4.9: v2.2.6/3.0.x (manual inst.) works well. I have 2D/3D acceleration enabled and (maybe therefore) have to switch video output to "OpenGL" or "Direct3D" (slightly slower) in order for it to work. Then videos can be played, including sound.
----
The following are legacy versions of a German slideshow application (available in multiple languages).
Aquasoft DiaShowXP Studio 5.7.01 (Commercial)
  • 0.4.2: Works well, albeit with some UI glitches (UI elements overlapping in some dialogs)
  • 0.4.5: Works. No UI glitches found in a quick check. 0.4.8: After show finishes, UI is not redrawn. Sound doesn't play.
Aquasoft Diashow 6.4.03 (Commercial)
  • 0.4.2: Installation stops with System error during SPTD setup but then finishes. Application works, however afterwards ReactOS show warn message on boot, trying to load an SPTD.sys which does not exist. Notes 1.) Only software player can be used if DirectX is not working, but it is completely usable.
  • 0.4.6-0.4.7: Inst. works, application starts. Toolbar icons missing, but UI is usable. Playback initially failes both in software and DirectX mode, showing "Preparing show ..." screen forever. After initial start of the application and switching to software player, I did a ReactOS restart and then software playback worked. So ... "works with luck".
  • 0.4.8: Inst. works, but installed link does not open application, but folder of 5.7 version (???). After loading a show, application froze at 100% CPU. Next time it worked, including playback. No sound.
Aquasoft Diashow 6.6.03 c'tNL-Editon (Needs free registration: http://www.aquasoft.de/ctNL_DiaShowDeluxe6_download.as)
  • 0.4.2: Installation works, but next reboot reveals problem with SPTD.sys in System32\Drivers, which is a driver for burning CDs. Start cancels with ELocalesError "Can not get Locale info".
  • 0.4.6-0.4.9: Installation works, but next reboot reveals problem with SPTD.sys in System32\Drivers (Error will be shown on every reboot). Start is OK, registration with the free code works. Loading demo show as well. Toolbar icons mostly black. Playback with software player in fullscreen or window mode works (with good performance). Playback in DirectX mode fails (black screen with showing "Preparing show ..." dialog forever). No sound.
  • 0.4.7: Installation works, but missing boot driver SPTD.sy prevents ROS from starting. -> Unusable. (
Aquasoft Diashow 8.6.03 (Commercial)
  • 0.4.2: Installation works, but fails to start with an unhelpful error.
  • 0.4.5-0.4.9: Installation fails with "Runtime error in script: Access violation at address 0045BBE4 in module 'Setup.exe'. Read of address 00000010". Compatibility mode doesn't help.
Diashow for YouTube 9.7.3 (Freeware: http://www.aquasoft.de/diashow/youtube)
  • 0.4.2-0.4.9: Installation works, but error on start. If "continue" is clicked then application starts very slowly and freezes usually before fully loaded. (CORE-13752) Unusable.
Aquasoft Stages 10 (32 bit) (Commercial, demo)
  • 0.4.5: Inst. OK, but start results in blue screen (BSOD) in win32k.sys, Address F5E63A44
3D tests
dxdiag (with Mesa driver installed beforehand)
  • 0.4.6-0.4.9: DirectDraw test OK, Direct3D test fails.
OpenGL Ext. Viewer 3.0
  • 0.4.6: The rendering test itself works, but the application UI is hardly usable and provides few infos.
3DMark05 1.3.0_1901
  • 0.4.9: Installation works. On start, error dialog "Errors occured while initializing Futuremark SystemInfo" ...", then application closes.
3DMark06 1.2.0
  • 0.4.6: Installation fails: "Feature transfer error" -> "Not enough storage is available" (But there is plenty of HDD space, so what?)
  • 0.4.9: Installation starts copying files, then BSOD with PAGE_FAULT_IN_NONPAGED_AREA in NTOSKRNL.EXE, Address 808E2AF0 base at 80800000.
Games
Bridge Constructor Playground (2D game from c't magazine 2014 CD)
  • 0.4.6: Inst. OK. and game can be played, albeit without sound.
  • 0.4.7-0.4.9: Inst. declares it has finished, but completely freezes ROS on pressing the Close button. After reboot it becomes obvious that installation is incomplete.
Extreme Tux Racer 0.4
  • 0.4.6-0.4.9: Inst. OK. and game works well in window mode (modify options.txt for this). In fullscreen mode the mouse is extremely overreacting, making the menu almost impossible to navigate. Performance is very good. No Mesa driver required.
Extreme Tux Racer 0.6/0.7.4
  • 0.4.2/0.4.6: Installation works, but fails to start. Complains and aborts: "The procedure entry point GetUserDefaultLocaleName could not be located in the DLL KERNEL32.dll." Reason: This function was introduced in Vista (see CORE-13766) -> incompatible.
Kyodai Mahjongg 1.42 (via application manager, which listed it as 21.42 prior 0.4.8)
  • 0.4.2/0.4.7-0.4.8: Installation works, but after option window only shows black window in both 2D and 3D game mode, as long as the sound is enabled (which it is by default) CORE-8380
Kyodai Mahjongg 2D v19
  • 0.4.2/0.4.5: Installation works, first start is extremely slow, flickering text, config dialog almost unusable (almost invisible). Subsequent starts are fast, game works fine (albeit without sound).
Kyodai Mahjongg 17.24
  • 0.4.6-0.4.9: Installation works, but settings dialog at start is unusable, not only because nearly invisible, but because the OK button cannot be pressed to continue.
X-Plane 9.7 Demo (Flight simulator, free for private use)
  • 0.4.9: Installation works including downloading files. Rendering extremely slowly (with Mesa driver). Performance much better without Mesa. Sound works (may be garbled as usual). Airplane can be navigated by mouse and keys.
Other software
Gramps AIO 3.4.7 (OS genealogy software, older version)
  • 0.4.2/0.4.8: Works
Google Earth 5.2 (Offline installers)
  • 0.4.6/0.4.8: Inst. works, but error at start: "System DLL user32.dll was relocated in memory [...] because [...]\GoogleEarth\client\MSVCP80.dll occupied an address range reserved for ReactOS system DLLs."
Google Earth 6.2.2 (Offline installers)
  • 0.4.6-0.4.9: Mesa is required! Installation and application works in OpenGL model (performance quite good). Searching doesn't work (fails to list results or jump)
Google Earth Pro 7.1.2 (Offline installer)
  • 0.4.6-0.4.8: Requires Mesa driver! Installation and application works in OpenGL model (performance acceptable).

Matthias
Last edited by matthiasbasler on Thu Jun 07, 2018 10:40 pm, edited 38 times in total.

Spinwiz
Posts: 19
Joined: Sat Sep 10, 2016 3:53 am
Location: QLD Australia

Re: Additional software tests

Post by Spinwiz » Mon Sep 19, 2016 4:50 am

RE: Postby matthiasbasler » Sun Sep 18, 2016 3:08 pm
Nice list. Ive been looking for people testing 'Third Party' apps on ReactOS. I'm only new to the forum so I am still feeling my way around.
Ive watched ROS for years but havn't had any success in getting it to boot until recently. I have now thrown about 2000 software titles at it, most fail for one reason or another.
I'm near the end stage of compiling a list of most that I have tested including a basic explanation of what failed, including the same tests on an old Toshiba Tecra laptop.
I'll most likely post a summary on a thead I started in 'Off Topic' and get some feedback before posting in Main forums.
viewtopic.php?f=13&t=15797
Alex =)

matthiasbasler
Posts: 35
Joined: Sun Sep 18, 2016 9:53 am

Re: Additional software tests

Post by matthiasbasler » Sun May 28, 2017 5:17 pm

Hi all,

I updated the application compatibility list above for ROS 0.4.5 as far as I did tests. (I didn't test any applications again, as it became clear that there is not a big difference to ROS 0.4.2.

I am sorry to say that I am a bit disappointed about the outcome of today's tests. Of course, ReactOS is alpha, but I wonder why the above listed fundamental bugs and flaws in the explorer (which become apparent more or less immediately if using it for file management) have not been addressed. It can only mean that the developers use 3rd party applications for file management, otherwise they would go crazy... :?

Compatibility for my software stack has not improved in 0.4.5 either, but luckily it's not become worse either.
Of course, I don't expect ROS to be a great multimedia OS at this stage, so I personally would put LibreOffice compatibility high up the list, as this is a "should-have" software for any OS which wants to gain acceptance in the OpenSource scene. OpenOffice 4.1.2 is a good alternative, but seems more or less replaced by LO these days. Just my opinion though.

Good luck and all the best with your project.
Matthias.

dizt3mp3r
Posts: 1450
Joined: Mon Jun 14, 2010 5:54 pm

Re: Additional software tests

Post by dizt3mp3r » Mon May 29, 2017 12:39 am

Matthias, you said it - ReactOS is alpha, something that may have worked yesterday may not work today.

Also, you are surprised that people haven't worked on the bugs that annoy you the most?
Well, the people that develop aren't really interested in resolving usability issues when the whole o/s is still under development and there are hundreds of bugs to be fixed. Some of the issues you are encountering may well be fixed when the fundamental issues are resolved/developed.

Don't expect ReactOS to be usable. Expect it to fail, please raise bugs as it does, watch this space and see ReactOS improve dramatically over time. When it is out of alpha everyone here will shout loud and you can see if your bits then work.

hbelusca
Developer
Posts: 1133
Joined: Sat Dec 26, 2009 10:36 pm
Location: Zagreb, Croatia

Re: Additional software tests

Post by hbelusca » Mon May 29, 2017 1:33 am

Hi!
It's just only now that I've noticed this forum thread, and I've asked on IRC about this and I was told that indeed almost nobody noticed it.
This is sad, because it looks like this was a work done in parallel and partial unawareness from the devs & other testers side, while the 0.4.5 release was in the process of being released. Indeed in other threads other people were being redirected to the "official" tests-for-0.4.5 wiki page, where programs & their run-test results were listed. The page can be found there : https://www.reactos.org/wiki/Tests_for_0.4.5 .
As I can see, future releases will also use such wiki pages so, it would be better for everybody (and for you, matthiasbasler, because you took quite a lot of time to test many apps & compare them against 0.4.2), if you could link your test results (and your future ones too!) to the respective wiki page.
Thanks!

matthiasbasler
Posts: 35
Joined: Sun Sep 18, 2016 9:53 am

Re: Additional software tests

Post by matthiasbasler » Mon May 29, 2017 6:21 pm

hbelusca wrote: ...
This is sad, because it looks like this was a work done in parallel and partial unawareness from the devs & other testers side, while the 0.4.5 release was in the process of being released. Indeed in other threads other people were being redirected to the "official" tests-for-0.4.5 wiki page, where programs & their run-test results were listed. The page can be found there : https://www.reactos.org/wiki/Tests_for_0.4.5 .
As I can see, future releases will also use such wiki pages so, it would be better for everybody (and for you, matthiasbasler, because you took quite a lot of time to test many apps & compare them against 0.4.2), if you could link your test results (and your future ones too!) to the respective wiki page.
Thanks!
Hi hbelusca,
I was well aware of the wiki page you mention. Actually I had it open all the time to cross-check what others had found and if they had listed a bug report already.
The reason I did not put my findings on that page are
  • I got told that the "Tests_for_0.4.5" is to be populated only before the release and is locked afterwards. See my question and answer in this forum entry. Note that I do my tests after the release.
  • I was under the impression that this page is primarily for "official" software (such as the one supported by the application manager) and not for out-of-focus software, such as my slideshow or panorama software or games I like.
If you think there was a misunderstanding and that my test results should better belong to that page (and the page is not locked!) I can take the time to update that page. But I don't want to step on someone's toes by doing so.

Matthias

oldman
Posts: 1072
Joined: Sun Dec 20, 2009 1:23 pm

Re: Additional software tests

Post by oldman » Mon May 29, 2017 8:08 pm

You could, if you wanted, use your own personal wiki page https://www.reactos.org/wiki/User:Matthiasbasler. All registered users seem to have a personal wiki page; I have used my page for my Layman's guide.
Please keep the Windows classic (9x/2000) look and feel.
The layman's guides to - debugging - bug reporting - compiling - with some complementary scripts.
They may help you with a problem, so do have a look at them.

matthiasbasler
Posts: 35
Joined: Sun Sep 18, 2016 9:53 am

Re: Additional software tests

Post by matthiasbasler » Sun Sep 03, 2017 9:32 pm

Today I've updated the software tests for ROS 0.4.6. There were a few changes, both positive and negative:

Improvements
  • I was able to get 3D drivers installed and have a working VLC player at the same time. Figured out the correct "video output" setting to use ("OpenGL" or "Direct3D", which is slower).
  • AC97 audio driver working again. (Either I did a mistake with 0.4.5 or it really wasn't working.)
  • With OpenGL Ext. Viewer test I finally have some proof that OpenGL rendering is working.
  • Firefox 48 + Flash 26 means that both HTMLK5 and Flash videos on the web can be viewed. (HTML videos without sound.)
  • Installation of all .net libraries now works.
  • Libreoffice 5.2 and 5.4 can be installed and work ... somewhat. That is, if you are very patient ...
Regressions
  • PhotoImpact 10 does no longer work (fails to see and open images)
  • Diashow 6.4.03 does no longer work (not able to play the slide shows any more). Worked well on second installation attempt.
  • Kyodai Mahjongg 17.24: I used to get the program over the problematic setup screen on start, but not any more on ROS 0.4.6.
Matthias
Last edited by matthiasbasler on Tue Sep 05, 2017 7:39 pm, edited 1 time in total.

PurpleGurl
Posts: 1778
Joined: Fri Aug 07, 2009 5:11 am
Location: USA

Re: Additional software tests

Post by PurpleGurl » Tue Sep 05, 2017 1:12 am

You should likely report the regressions in Jira unless of course they are already reported there. It seems there's a common denominator in what you've posted as failed in at least 2 cases.

matthiasbasler
Posts: 35
Joined: Sun Sep 18, 2016 9:53 am

Re: Additional software tests

Post by matthiasbasler » Tue Sep 05, 2017 6:50 pm

PurpleGurl wrote:You should likely report the regressions in Jira [...].
Yeah, thought about it. But first of all, neither of the three affected programs is available for download in the tested version (any more), so no developer could do tests with them. And second, all of them are not part of the RAPPS list and I remember having read that the developers focus on RAPPS applications and do not want to get bugged with someone's personal favourites. (And seeing the number of "Failed" on https://reactos.org/wiki/Tests_for_0.4.6 there's quite some work to be done to get even most of those applications running well.)

Matthias

dizt3mp3r
Posts: 1450
Joined: Mon Jun 14, 2010 5:54 pm

Re: Additional software tests

Post by dizt3mp3r » Tue Sep 05, 2017 7:14 pm

Just raise them on Jira - then the devs at least have a chance to accept and fix them. If you decide not to raise a bug then don't expect them to fix it.

middings
Posts: 1008
Joined: Tue May 07, 2013 9:18 pm
Location: California, USA

Re: Additional software tests

Post by middings » Tue Sep 05, 2017 9:28 pm

matthiasbasler wrote:[None] of the three affected programs [are] available for download in the tested version (any more), so no developer could do tests with them.
When a reported bug is known to occur only in an application that is not available to the development team (devs) and there is no volunteer who has a licensed copy of the application willing and able to perform tests the devs ask for, the issue is usually marked "Could not reproduce" and closed.

If the bug report includes a reduction of the bug to a small program that reproduces the fault then the devs will keep the issue open until it is resolved. Bug reduction is a valuable skill. Unfortunately, most bug reporters (including me) lack the skills necessary to reduce even trivial bugs.
[...]I remember having read that the developers focus on RAPPS applications and do not want to get bugged with someone's personal favourites.
I believe this is true. However, this should not be a reason to avoid making a good bug report with a clear description of what was expected to happen and what actually happened, plus a backtrace. The worst that can happen is that the devs consider that bug report to have such a very low priority that they never work on that bug. Yet, the bug reporter might get lucky. Sometimes "someone's personal favourite" program is a dev's personal favorite too. Or the new bug report reveals new information about a previously reported bug exposed by another application program. Then a sudden flurry of developer activity to attack that bug might occur.
(And seeing the number of [programs marked]"Failed" on https://reactos.org/wiki/Tests_for_0.4.6 there's quite some work to be done to get even most of those applications running well.)
They also serve who only test.

The ReactOS project can always use more people who will test applications. Ideally every listed application would be tested with every release candidate, with every release, and tested again every few hundred revisions between releases. Also ideally, those who report a bug that occurs with an application that is not on the list would re-test the affected application with every release candidate and at least once every thousand revisions between releases until the bug is resolved.

matthiasbasler
Posts: 35
Joined: Sun Sep 18, 2016 9:53 am

Re: Additional software tests

Post by matthiasbasler » Tue Sep 05, 2017 10:00 pm

oldman wrote:You could, if you wanted, use your own personal wiki page https://www.reactos.org/wiki/User:Matthiasbasler. All registered users seem to have a personal wiki page; I have used my page for my Layman's guide.
Hi oldman, thanks for your tip. I also created a tutorial on my page, so as to prevent other new users from falling into the same pitfalls during installation and configuration as I did ... and because in half a year I might have forgotten this or that detail to pay attention to.
https://www.reactos.org/wiki/User:Matthiasbasler

I think it complements your layman's guide well, because yours is more for contributors an mine is for end users who just want to try out ReactOS.

Matthias

oldman
Posts: 1072
Joined: Sun Dec 20, 2009 1:23 pm

Re: Additional software tests

Post by oldman » Wed Sep 06, 2017 10:47 am

matthiasbasler wrote: Hi oldman, thanks for your tip. I also created a tutorial on my page, so as to prevent other new users from falling into the same pitfalls during installation and configuration as I did ... and because in half a year I might have forgotten this or that detail to pay attention to.
https://www.reactos.org/wiki/User:Matthiasbasler

I think it complements your layman's guide well, because yours is more for contributors an mine is for end users who just want to try out ReactOS.

Matthias
Very good!

Why not use your signature to advertise this thread and your tutorial (User Control Panel - Profile - Edit signature).
Please keep the Windows classic (9x/2000) look and feel.
The layman's guides to - debugging - bug reporting - compiling - with some complementary scripts.
They may help you with a problem, so do have a look at them.

matthiasbasler
Posts: 35
Joined: Sun Sep 18, 2016 9:53 am

Re: Additional software tests

Post by matthiasbasler » Sat Dec 09, 2017 7:52 pm

Today I updated the above software compatibility list for ROS 0.4.7 release. I did not check every software version, but most of them.

Unfortunately there wasn't any progress specifically regarding the compatibility of the software tested by me. On the contrary, I encountered two regressions:
  • Adobe Flash player online installer (version 27) does not work with 0.4.7 (it works with 0.4.6, even if not perfect) -> CORE-13952
  • The game "Bridge Constructor Playground", which used to work well on 0.4.6 now freezes ROS 0.4.7 at the end of the installation.
On the positive side some of the listed explorer issues were fixed and copying/moving files is now much more reliable.

Post Reply

Who is online

Users browsing this forum: Google [Bot] and 1 guest