PC ROS Rigs

From ReactOS Wiki
Jump to: navigation, search

This page is to get an overview of PC systems as a whole that worked with ROS. It is not meant to detail how you tested it, what you tested it for, and what specific errors or trials you had to do. For that, you can use the forum or other means. One of the most active topics on the forum about testing ReactOS on real hardware is: ROS testing on real hardware. Even if you start a new topic on the forum try to link to it from that topic.

To have a more formal and structured approach, please fill in the following data in this way:

  1. Name tester
  2. Name/model/brand of the PC, (laptop or desktop)
  3. Name/model/brand of the CPU, GHz
  4. Amount/kind of RAM;
  5. HD brand, GB, kind
  6. Motherboard
  7. Videocard (integrated or not)
  8. Soundcard (integrated or not)
  9. Ethernetcard (integrated or not)
  10. Which version of ROS you used (build, release...if additional builds are successfully used on the same machine, just add it with ; )
  11. Brief comments (specifically related to how well it worked, or reference to detailed testing)
  12. Feel free to update appropriate sections of Supported Hardware page (especially Supported USB Devices)

Real Hardware Testing (rig)

Tester Computer CPU RAM HD Size Motherboard Video Card Sound Card Ethernet Card Revisions Tested (Working / Not Working) Comments & Regressions
cgutman, Christoph_vW, Colin_Finck, dreimer, ekohl, gadamopoulos, HeisSpiter, janderwald, Pigglesworth, tamlin, ThFabba, tkreuzer, zefklop Dell Latitude D531 AMD Turion 64 X2 1 GB DDR2 80 GB SATA ATI SB600 ATI Radeon X1200 Realtek HD Audio Broadcom 57XX ?? Official ReactOS testing notebook, keyboard works since r62517, touchpad works since r63126, network since r66512, wlan since r66514, USB does not work
Webunny custom 1 (desktop) Intel P4 1,8 GHz 768 MB SDRAM Seagate 40 GB IDE Aopen mx4bs NVIDIA Vanta 16 MB CMedia-8738 realtek RTL8139C REL 0.3.15; build 61357; 0.3.16 RC1 ; 0.3.16 RC2 ; REL 0.3.16 ; build 62368 ; build 62707 ; 0.3.17 RC1-4 Works as it should, all later builds do not, unless I remove the sound card. Works again with build 61357 (see details testing) With RC1 to 4: problems getting sound again (driver not installing?). Will do regression-testing again.
Igor Tsigankov RoverBook Navigator MT7 Intel® Pentium® III 933-1260 256 mb SDRAM PC-133 Toshiba 40 gb 2.5" UDMA-100 SIS 630S SIS 630ST SoundBlaster™ Pro 10Base-T/ 100Base- TX UTP 0.4-SVN 20140617-r63612 http://vk.com/reactos_ru?w=wall-1086956_11406%2Fall


oldman Fujitsu ErgoPro Pentium-2 233 MHz 96 MB 3.2 GB IDE Fujitsu S3 Virge DX PCI None PCI (Realtek 8139c chip) R61281 R61666 R61848 Works
oldman Generic AMD Athlon 64 Processor 3200+ 1 GB ATA 38 GB IDE LANPARTY UT nF3 250 GB MSI (nVidia) on board nVidia on board nVidia R61281 R61640 R61666 R61848 R62224 R62372 Works. The nVidia nForce3 drivers do not currently install.
oldman Dell Latitude D630 (Laptop) Intel Core 2 Duo 2.20Ghz 2 GB ATA ST980813ASG 80GB Dell 0WM416 nVidia G86M [Quadro NVS 135M] Intel 82801H (ICH8 Family) HD Audio Controller Broadcom NetXtreme BCM5755M Gigabit Ethernet PCI R63478 livecd-63712-dbg livecd-65317-dbg livecd-65503-dbg Fails to install in the first stage at "Building the file copy list ....".

Runs ok (livecd), touchpad works with no problems, I have been able to change the scr res to 1440x900 (monitor default). It failed to completely boot with a usb mouse attached, but boots ok when removed. With livecd-65503-dbg I can boot in normal mode (in debug, it fails at HIDUSB.SYS) with the usb mouse attached, which then works at the desktop.

oldman Dell Dimension 2400 Intel Pentium4 2.40Ghz 512MB ATA-100 40GB Dell OG1548 (Intel chipset) Intel i845G(L) Integrated Intel 82801DB(M) Broadcom 4401 10/100 Integrated livecd-63712-dbg Fails at kbdhid. Mouse and keyboard are usb. By replacing the USB mouse and keyboard with PS2, lets it go further. CORE-8364
oldman Generic AMD Athlon(tm) 64 X2 Dual Core Processor 3600+ 1GB SATA ?GB BIOSTAR Group GF7025-M2 SE nVidia C68 [GeForce 7050 PV/nForce 630a] Integrated nVidia MCP67 High Definition Audio) nVidia MCP67 Ethernet livecd-63712-dbg USB mouse, PS2 keyboard. Bios (Pheonix) only boots after several attempts.
middings HP Pavilion 7965 (desktop) Intel Pentium 4, 1.7 GHz 1.25 GB PC133 SDRAM Seagate ST34323A, 4.3 GB, Ultra ATA ASUS P4B-LA (Amazon), ASUS/AMI Bios NVIDIA TNT2 M64 AGP 4x 32 MB AC'97, ADI1885 CODEC (integrated) Intel PRO 100/VE, Kinnereth (integrated) 63181; 63269; 63534; 63682; 73604 (BootCD) All builds tested boot to desktop but could not install ReactOS's multimedia, audio, and Ethernet drivers. Slipstreamed Intel's network adapter driver, it installs but won't run. Forum discussion CORE-8340
wildschwein IBM Thinkpad R50e (laptop) Intel Celeron 1.5 GB  ??  ?? Intel Extreme Graphics 2 for mobile (82852/82855 GM) DirectSound, AC '97  ?? ?? Works (sound and ethernet not auto-recognised at startup)
gonzoMD IBM Thinkpad T21 (laptop) Intel Pentium III 256 MB  ??  ?? S3 Savage Crystal Fusion Intel Pro100+ MiniPCI ?? Works (some difficulty with sound)
LambdaCalculus379 IBM Thinkpad T40 (laptop) Intel Pentium M (Banias), 1.5 GHz 768MB 20GB IDE - ATI Mobility Radeon 7500 (32MB VRAM) Intel AC'97 Audio Intel Gigabit Ehternet (10/100/1000) 0.4.4 Tested with WinXP drivers from Lenovo support page; drivers need to be installed manually as installer programs fail
ConductiveDielectric Toshiba Tecra 8100 (laptop) Intel Pentium III 128 MB SDRAM 20 GB IDE - S3 Savage/MX(TM) chip w/8MB SGRAM Integrated Xircom RealPort(TM) Ethernet 10/100 RE-100 LiveCD r62260 with removed FLOPPY.SYS With FLOPPY.SYS included (default configuration) boot stops at this screen. When it is removed from the build the BootCD successfully goes through the first stage of installation but BSODs in the second stage. LiveCD, however, seems to work fine. https://jira.reactos.org/browse/CORE-7935
milon Shuttle XPC Intel® Atom D525 Dual Core 1.8 GHz 1 GB DDR3 250 GB SATA Intel MN10 Chipset (board unknown) onboard GMA 3150 onboard onboard 802.11b/g/n, 10 MB/s,100MB/s,1GB/s Latest Test:
bootcd-63609-dbgwin
livecd-63612-dbg
No optical drive means USB Booting – suspected source of BSOD
milon Ye Olde Desktop Intel Pentium Dual-Core E5300 2.6 GHz 2 GB 600 GB (Partitioned into 50 GB Win7 and 540 GB storage) Asus P5Q-VM Onboard Onboard D-Link DWA-542 Wireless + Onboard ethernet (Realtek) pre 0.3.15 to 61261 USB Booting is a potential source of BSOD's, but it never successfully booted from CD either
adrian15 Cadox 1998 AMD K6 II – 233 Mhz 160 MB ST34312A ATA 4 GB J-TX98B SiS 5597/5598/6326 VGA (rev 65) (Integrated) CMI8330 (Sound Blaster compatible in Gnu/Linux) (Integrated) None None UNIATA driver seems to hang even when switched with ATAPI driver
Tester Computer CPU RAM HD Size Motherboard Video Card Sound Card Ethernet Card Revisions Tested (Working / Not Working) Comments & Regressions
roytam DELL GX520 Pentium 4 3.0 GHz (Socket 775) 512 MB 80 GB Intel 945G Intel GMA950 Integrated Analog Devices ADI1981 BroadCom BCM5701 None CORE-7962 for CD Boot, CORE-7963 for USB Boot
roytam DELL Optiplex 330 Pentium E2160 512 MB 80 GB Intel G31 Intel GMA 3100 Integrated Analog Devices ADI1984 BroadCom BCM5787 63477 Live CD
roytam VIA PC2500 VIA C7-D 1.5 GHz 2048 MB 80 GB VIA CN700 + VIA VT8237R Plus VIA CN700 UniChrome Pro Realtek ALC655 VIA VT6103 63477 Live CD CORE-7961
Black_Fox Lenovo T400 (6475-ZUU) laptop Core 2 Duo T9400, 2.53 GHz 4 GB DDR3 160 GB Hitachi HTS723216L9SA60 Lenovo 6475ZUU (Intel GM45 + Intel ICH9M) GMA 4500MHD integrated integrated (TBD) Intel 82567LM ICH9M(E+) LiveCD: 62417, 62552, 64577, 64945, 65369, 66512 67545 70758 LiveCD works now. Cannot test BootCD.
Black_Fox Lenovo T400 (????-???) laptop TBD TBD TBD TBD TBD TBD TBD LiveCD&BootCD: 62417, 62552, 64577, 64945, 65369, 66512, 67545 LiveCD: 69882 BootCD fails, USB fails (CORE-7968). Normally runs Win7.
Black_Fox Toshiba Satellite A50-101 laptop Pentium M 7150, 1.5 GHz 1 GB DDR 100 GB Seagate ST910021A Intel 82801DB ICH4 Intel 855GME Intel 82801DB/SigmaTel STAC9750-51 Intel PRO/100 VE + Intel PRO/Wireless 2200BG LiveCD: 67545, 70758 BootCD: 63429, 64577, 67545, 70758 BootCD works since long past (2010), but it will fail if I set "Legacy USB->FDD" to on – CORE-8263. External drivers: LAN works, sound STAC97 fails (CORE-8693). LiveCD currently regressed, cause unknown - displays messagebox "SHGetFolderPathW failed hret=0x80070002" (and probably bugchecks).
Black_Fox Toshiba Satellite L300-2C7 laptop Pentium Dual-Core T4300, 2.1 GHz 2 GB DDR2 320 GB HDD <chipset TBD> GMA 4500M integrated <soundcard TBD>  ?? + Atheros XB63L LiveCD: 64945, 67545 LiveCD works. Cannot test BootCD.
Black_Fox Toshiba Satellite 2520CDS laptop AMD K6-2, 300 MHz 32 MB EDO 4 GB HDD <chipset TBD> S3 Virge MX 86C260 integrated <soundcard TBD> <network TBD> LiveCD&BootCD: 64945 FreeLDR won't even start loading, can't allocate enough memory => This machine will never work.
Black_Fox Custom ION HTPC Intel Atom 330, 1.6 GHz 4 GB SO-DIMM DDR2 2 TB HDD + 500 GB HDD MCP7A-ION ION (unused) + AMD HD 5450 Realtek ALC662 HDA Realtek 8112L LiveCD: 64945, 67545, 69882 LiveCD fails on Phase1Initialization - CORE-9671 and on UniATA - CORE-10576. Cannot test BootCD installation. Normally runs Win7.
c6h6nh2 MSI VR321 VIA C7-M 1 GHz 1024 MB 80 GB VIA VN896+VT8237A VIA Chrome 9 Realtek HD Audio VIA Rhine II/Atheros AR5007EG wireless 62528 Install only standard uniprocessor, installing sound card or video card drivers going to BSOD
c6h6nh2 IBM ThinkPad A31 Intel P4-M 1.6 GHz 512 MB 20 GB Intel 82801/82845 ATI Mobility Radeon 7500 16 MB DDR AC'97/Intel 82801 Intel PRO/100 VE 62528 Sound card works, install video card driver going to BSOD
eersoy93 Toshiba Satellite A210-199 AMD Athlon 64 X2 TK-57 3 GB DDR2 250 GB ATI SB600 ATI Radeon X1200 Realtek HD Audio  ??? 59002, 59456, 59992 (LiveCD), 59992 (BootCD), 60147 (LiveCD), 60147 (BootCD) See more information: CORE-6791
eersoy93 Lenovo G580 Intel Core i5-3320M 4 GB DDR3 500 GB LENOVO Product Name (U3E1) Intel HD Graphics 4000 and NVIDIA GeForce 610M HD Audio Qualcomm Atheros AR8162/8166/8168 PCI-E Fast Ethernet Controller 63131 (LiveCD), 64055 (LiveCD), 66113 (LiveCD) Everse SM-302 USB mouse doesn't work. I couldn't connect to my modem (NetMASTER CBW-700V) via wireless and Ethernet cable. 66133 => Logitech M195 USB mouse doesn't work. I couldn't connect to my modem (ZyXEL P-660W-T1 v3 (IPv6)) via wireless.
Zombiedeth custom Intel Pentium 4 631 3 Ghz 3 GB DDR2 N/A Intel D945GTP Intel 945G (integrated) Sigmatel Stac9220 (integrated) Intel Pro/1000PM (integrated) 63643 (LiveCD) Logitec K120 USB Keyboard doesn't work.
ChrisB HP nx6110 Intel Celeron M 1,4GHz 512 MB Hitachi 40GB IDE Intel 915GM SoundMax AD1981B Broadcom 4401 63725 Boot CD USB, graphics, audio, ethernet not working. KBD & Touchpad OK
Sansveni Thinkpad X200 (Lenovo) Tablet Intel Core 2 Duo SL9400 1.86 GHz 2x2GB DDR3 WD 160GB SATA (WD1600BEVT); Fujitsu 160GB SATA(MHW2160BH) GM45 Express Chipset Intel GMA 4500M HD (integrated) Conexant 20561 SmartAudio HD Intel 82567LM Gigabit (integrated) R63877 (LiveCD); R63877 bootcd; R63887 bootcd; REL 0.4.0; R71300 bootcd; REL 0.4.5 trackpad, keyboard, DVD drive via dock (seems to only work during install) & 1280x800 32-bit color work; ethernet, wifi, and sound don't work; NEW on 0.4.5: USB works!
Sansveni HP Pavilion s7520n Desktop AMD Turion 64 ML-34 1.8GHz 1x1GB DDR 400 Seagate 250 GB 2.5" SATA II Opal-GL6E (chipset: ATI Radeon Xpress 200) ATI Radeon X300-based integrated Realtek (?) AC'97 Realtek RTL8139/810x (according to driver) REL 0.4.0 PS/2 mouse & keyboard, DVD drive (IDE), & 1024x768 w/ 32 bit work (best option), ethernet works (not default driver); sound and USB do not work.
Pi_User5 Dell Dimension L733r Intel Pentium III 733 MHz 512 MB SDRAM 40 GB IDE Intel Video-118PCI Creative ES1373 Accton EN-1207D 75029 (BootCD) Chose Standard PC instead of a ACPI computer in setup.
Pi_User5 Dell Inspiron 530s Intel Core 2 Duo E7400 2.8 GHz 3 GB DDR2 RAM 60 GB SATA (IDE Emulation) Intel MSI GeForce GT 710 Realtek ALC888 HD Audio Intel 825xx 10/100 66105 HybridCD I am using a HybridCD off a USB drive. I selected LiveCD in RAM to boot from the USB drive.
Pi_User5 Dell Inspiron 6000 Intel Pentium M 730 1.6 GHz 1 GB DDR2 RAM 30 GB IDE Intel Intel 915GM SigmaTel C-Major Audio Broadcom 440x 10/100 75029 BootCD Audio driver causes lockup on shutdown.
Pi_User5 Compaq nx6325 AMD Turion 64 X2 Mobile TL-52 1.6GHz 2.5 GB DDR2 60 GB ATA HP 30B0 ATI Raedon Express Series SoundMAX Integrated Digital HD Audio Broadcom NetLink Gigabit Ethernet 64555 (LiveCD); 0.3.17 (BootCD) ; 65490 (BootCD) ; 65825 (LiveCD) ; 65490 (BootCD) ; 68595 (LiveCD) The 0.3.17 branch setup will not start. Daily builds will. I no longer have this machine.
johngoner Dell Dimension 3000 (desktop) Pentium 4 2.8 512MB DDR2 WDC WD800JB-00FMA0 80GB IDE Intel E210882 Integrated graphics using Intel 82865G graphics Controller Soundmax Integrated Audio Integrated network using Intel PRO/100 VE Network Connection livecd-65034-dbg and Release version 0.3.16 Blue screen on both versions
johngoner Toshiba Satellite R10 (generic convertible laptop) Intel Centrino Pentium M735 1.7 512MB DDR SDRAM PC2700 Toshiba MK6025GAS ATA motherboard Integrated graphics using "Standard VGA Graphics Adapter" Soundmax Integrated Digital Audio Integrated network using Intel PRO/100 VE Network Connection and Intel PRO/Wireless 2915ABG Network Connection livecd-65034-dbg and Release version 0.3.16 Blue screen on both versions
laurflorin Acer Aspire E1-571G (laptop) Intel Core i7-3632QM 2.2Ghz 4GB DDR3 500GB HDD (IDE mode) EA50_HC_CR (U3E1) Intel HD 4000 integrated and NVIDIA GeForce 710M 2GB dedicated VRAM Realtek High Definition Audio Broadcom NetLink Gigabit Ethernet (LAN) and Intel(R) Centrino(R) Wireless-N 105 (WLAN) livecd-65327-dbg (Working) Works in thie left-mentioned revision, but not in ReactOS 0.3.17
henrytang5247 Asus A43SJ (Laptop) Intel Core i5 2430M 2.4Ghz 6GB DDR3 Hitachi 640GB HDD SATA K43SJ NVIDIA GeForce 520M 1GB Realtek High Definition Audio Realtek PCIe GBE Family Controller (LAN) and Atheros AR9002WB-1NG (WLAN) livecd-r65539-dbg Worked well. But USB not worked.
Tester Computer CPU RAM HD Size Motherboard Video Card Sound Card Ethernet Card Revisions Tested (Working / Not Working) Comments & Regressions
morbip Dell Dimension 2300 Intel Pentium 4 2.0 GHz 512MB SDRAM Maxtor 2GB PATA Dell Bluford E139765 Intel 845G (Integrated) Analog Devices ADI 1980 (Integrated) Intel PRO/100 M PCI R70760 (bootcd) R70702 (bootcd} Works with USB controller disabled and no audio (drivers freeze on install)
morbip Dell Dimension 3000 Intel Pentium 4 3.0 GHz 2GB DDR SDRAM Maxtor 2GB PATA Dell E210882 Intel 82865G (Integrated) Intel 82801EB AC'97 SoundMax (Integrated) Intel PRO/100 VE (Integrated) R70788 (bootcd) No audio or NIC. USB works sporadically.
kowalskilover32bit HP Compaq dx 2300 Intel Pentium 4 3.0 GHz 512MB DDR SDRAM HITACHI 80GB SATA HP N1996 Standard VGA UNKNOWN Intel Ethernet addapter bootcd ver 4.0 Gets stuck on splash screen.
william341 Dell Latitude D430 Intel Core 2 Duo 1.66GHz 2GB DDR2 SDRAM 80GB SATA Unknown Intel 945GM STAC9278 B57xx bootcd 71495, livecd 71495 71495 Needs to be installed manually (eg. with clonezilla). Has no CDROM drive. DBAY needs SCSI CDROM support. Touchpad as of 71495. Network as of 71495. WiFi not working. Sound not working. 945 will not report full resolution of 1280x800.
Domehead Medion MD42100 Intel Pentium M 1.8GHz 2GB DDR SDRAM 128GB mSATA to PATA SSD Unknown Intel 82852/82855 Graphics Controller AC'97 SoundMax (Integrated) VIA Rhine III Fast Ethernet Adapter and Atheros 5008 (with AR5416 chipset) bootcd 71645 716454 Can be installed normally. AC '97 audio driver will fail to work, even if installed manually, using installer will brick system. WiFi Card detected, driver installed but still fails to work. Installing latest graphics drivers will brick system upon reboot, forcing reinstall. Some key system drivers such as PCMCIA card and several system drivers will fail to load or are non-existent. Installing chipset driver will not work
Uityyy Custom AMD Athlon(tm) 64 Processor 3500+ 4GB ~40GB PATA GeForce6100SM-M V:1.0 PCIe GALAXY Nvidia Geforce 8400GS 256MB DDR2 64Bit w/CRT/HDTV/DVI/PCIE (Integrated) Integrated + PCI: D-Link WIRELESS DWA-525 Rev. A1 (v. 1.10) 0.4.4 Removed audio .sys drivers to and USB mass storage drivers (.sys) to boot successfully. Latter may be issue with 058f:6377 Alcor Micro Corp. Multimedia Card Reader. Network untested. System in first 2GB of the first hard disk; stomachs existence of partitions for many other operating systems.
Krux Custom Intel Core i5-4460 8GB 80GB WDC SATA ASUS B85M/E-BR GIGABYTE Nvidia GeForce 750Ti (Integrated) (Integrated) release 0.4.4 (BootCD) Not able to load the system after first part of installation. Throwing "Opening hive file failed!" after selecting either "ReactOS" or "ReactOS(Debug)" options in FreeLoader.
isithran Custom Intel Atom 330 2GB 150GB WDC 10k SATA Gigabyte GA-GC330UD (BIOS F3) (Integrated: Intel 945GC) (Integrated: Realtek HD Audio/Azalia) (Integrated: Realtek 8102E Fast Ethernet) release 0.4.5 (20170513-74533 BootCD) Base system installs normally. Ethernet NIC needs external driver, no problem during install, works fine. Chipset driver installs without any issue. Audio driver installer gets stuck after copying files. USB keyboard recognized by the installer, but not by the OS afterwards. PS/2 keyboard works, need a PS/2 mouse to finish testing.
seijinshu Lenovo ThinkPad T420 Intel Core i5-2520M 8GB DDR3 150GB Fujitsu SATA II Drive in UltraBay Unknown (Integrated: Intel HD Graphics 3000 Mobile) (Integrated) (Integrated) 0.5-SVN (Build 75733-dbg-msvc BootCD); Release 0.4.6 BootCD; Please See Notes Had to install from VBox since I do not have the UltraBay DVD Drive, so real hardware BootCD remains untested. No USB Devices connected to the dock worked, only outputted to the current boot screen (DisplayPort monitor on my dock, internal display undocked, reboot required to switch displays), WiFi does not work OOB, installed drivers, remains untested, but detects the hardware. Ethernet untested. TrackPoint, Keyboard & UltraNav works (official Lenovo Drivers do not install), Chipset Drivers work, Graphics cause BSOD every boot after installation in every boot mode from IRQL_DRIVER_NOT_LESS_THAN_OR_EQUAL, requiring reinstallation of ReactOS. Sound not working (drivers not tested before the BSOD that killed the OS). LiveCD and USB Ports not on the dock remain untested.
Zac@ttack1229 Dell Dimension 3000 Pentium 4 512 MB DDR1 80 GB Stock Motherboard On Board Video (VGA) None Tested None Tested Revisions Tested (Working / Not Working) I used the stable 0.4.6 for my test. The only way I could get it to install was by setting the display to 16 bit VGA. It looks terrible but it installed. CDs and DVDs do not get read, USB sticks aren't even detected.
silasqwerty1 Gateway MX6025 Intel Celeron M 1.4GHz 1GB DDR1 160 GB Intel 852GM Chipset Intel Extreme Graphics 2 Intel 82801DBM ICH4-M - AC'97 audio controller Onboard Revisions Tested (BootCD b22c128) Installs fine. USB appears to work as well as it ever does on ROS, ethernet works fine with an external driver, and I did not test audio.

See Also